User:PeterSampson/Sand-Box

From Audacity Wiki
< User:PeterSampson
Revision as of 17:36, 4 November 2013 by PeterSampson (talk | contribs) (Previous Feature Requests relating to this proposal: WIP ignore)
Jump to: navigation, search

Proposal File Menu Reorganization

Proposal pages help us get from feature requests into actual plans. This page is a proposal to ...
Proposal pages are used on an ongoing basis by the Audacity development team and are open to edits from visitors to the wiki. They are a good way to get community feedback on a proposal.


  • Note: Proposals for Google Summer of Code projects are significantly different in structure, are submitted via Google's web app and may or may not have a corresponding proposal page.


The Problem

Users, new users in particular, are Confused about what 'export' and 'save' mean.


Proposed Feature

We should take the split between "projects" and "audio" to its logical conclusion and completely separate them in the menu structure. Better use of fly-out submenus.

  • 'Open' will be renamed 'Open Project' and ONLY open an Audacity project. If you try to open a wav file it will tell you about projects and tell you to import instead. This will help reduce the risk of users thinking they are genuinely opening and working on a wav file directly.
  • Recent Files will continue to operate much 'as currently'. If you import a file it will be added to the recent files list. If you select a non .aup file from the recently opened list it is imported.
  • Drag-and-drop opening of a .wav file will import the dragged audio into your current project.
  • It was previously suggested that'Check Dependencies...' should move to the proposed Tools menu, as it is a diagnostic tool. However although it isn't directly a "file" operation, it is intimately associated with saving projects. Moving it out to the Tools menu would potentially discourage its usage.


Developer/QA Backing

  • Peter


Use Cases

TBP


Details

Gale's alternative File Menu proposal

This assumes we do not allow an "Open" menu to open audio files. If we do this we should probably stop "Recent Audio", opening audio files in the file manager and dragging audio files to the Audacity icon opening new project windows.

This scheme lets us have a root menu item for straight export and import.

  • New Project
  • Open Project...
  • Recent Projects >
  • Check Dependencies...
  • Save Project
  • Save Project As...
  • Save Compressed Copy of Project...
  • Close Project

  • Edit Metadata...

  • Import Audio...
  • Import Special > | Audio in New Project... | MIDI... | Raw Data... | Labels...
  • Recent Audio > | Import | Import in New Project
  • Export Audio...
  • Export Selection...
  • Export Multiple...
  • Export Special > | MIDI... | Labels...

  • Edit Chains...
  • Run Chain...

  • Page Setup...
  • Print...

  • Exit


GUI Examples

TBP


Previous Feature Requests relating to this proposal

TBP


Side Issues

  • At this stage we are NOT proposing a mode where Audacity can switch over to using a wav file as if it were its project - much as Microsoft word can open a txt file, but then warns when you try to save it that 'some features/formatting can't be saved in text format'. It's not that hard to add, but it would go outside the scope of this proposal. This could be a good feature though and solve a lot of user confusion. If we were to do it, we'd list in the warning dialog what would be lost.