Difference between revisions of "User:PeterSampson/Sand-Box"

From Audacity Wiki
Jump to: navigation, search
(Proposed Feature: WIP ignore)
(clearing my sandbox)
Line 1: Line 1:
=Proposal File Menu Reorganization=
 
  
{{Proposal_Header|This page is a proposal to reorganize the File menu to provide distinct clarity between Audacity Projects and audio files, separating them in the menu. |}}
 
 
__NOTOC__
 
 
==The Problem==
 
Users, new users in particular, are confused about what 'export' and 'save' mean - a distibction made less clear as users can currently "open" an audio file with Audacity leading them to think that Audacity is a WAV, MP3, whatever editor.  Admittedly this problem (normally) diminishes as the user learns Audacity - but many postings on the forum indicate that this remains a problem for folk starting out with Audacity
 
 
Basically we need to make clear the distinction between native and non-native formats, using "Open" / "Save" only for native format (Audacity Projects) and "Import" / "Export" for non-native formats (audio files).
 
 
<font color="blue">'''Aside:''' and as Vaughan quoted in an unrelated email thread: ''"As the saying goes, '''"Confusion on our enemies" -- not on us!"''' "''</font>
 
 
== Proposed Feature ==
 
We should take the split between "projects" and "audio" to its logical conclusion and completely separate them in the menu structure.
 
Better use of fly-out submenus.
 
* 'Open' will be renamed 'Open Project' and ONLY open an Audacity project.  If you try to open a wav file it will tell you about projects and tell you to import instead.  This will help reduce the risk of users thinking they are genuinely opening and working on a wav file directly.
 
* The "Export..." command to be xtended to be "Export Audio..." or "Export Audio File..." for clarity of purpose.
 
** "Export Multiple..." could become "Export Multiple Audio..." or "Export Multiple Audio Files..." to maintain that clarity
 
*Commands that operate on Projects to be clearly separated in the menu from commands that work on audio files.
 
*Recent Files will continue to operate much 'as currently'.  If you import a file it will be added to the recent files list.  If you select a non .aup file from the recently opened list it is imported. 
 
* Drag-and-drop opening of a .wav file will import the dragged audio into your current project.
 
* It was previously suggested that'Check Dependencies...' should move to the proposed Tools menu, as it is a diagnostic tool.  However although it isn't directly a "file" operation, it is intimately associated with saving projects. Moving it out to the Tools menu would potentially discourage its usage.
 
 
==Developer/QA Backing==
 
*Peter
 
 
==Use Cases==
 
TBP
 
 
 
==Details==
 
 
=== Gale's File Menu proposal ===
 
 
This assumes we do not allow an "Open" menu to open audio files. If we do this we should probably stop "Recent Audio", opening audio files in the file manager and dragging audio files to the Audacity icon opening new project windows.
 
 
The key thing for me is that the item that does "export" has "audio" or "audio files" in the title.       
 
 
This scheme lets us have a root menu item for straight export and import.
 
 
{|
 
|- width="50%"
 
|
 
* New Project
 
* Open Project...
 
* Recent Projects >
 
* Check Dependencies...
 
* Save Project
 
* Save Project As...
 
* Save Compressed Copy of Project...
 
* Close Project
 
<hr>
 
* Edit Metadata...
 
<hr>
 
* Import Audio...
 
* Import Special > | ''Audio in New Project...'' | ''MIDI...'' | ''Raw Data...'' | ''Labels...''
 
* Recent Audio > | ''Import'' | ''Import in New Project''
 
* Export Audio...
 
* Export Selection...
 
* Export Multiple...
 
* Export Special > | ''MIDI...'' | ''Labels...''
 
<hr>
 
* Edit Chains...
 
* Run Chain...
 
<hr>
 
* Page Setup...
 
* Print...
 
<hr>
 
* Exit
 
|}
 
 
This schema is supported by Peter, Steve and Ed.
 
 
===GUI Examples===
 
TBP
 
 
==Previous Feature Requests relating to this proposal==
 
There don't appear to be any.
 
 
== Side Issues ==
 
* At this stage we are NOT proposing a mode where Audacity can switch over to using a wav file as if it were its project ''(for which there is a Pending Feature Request)'' - much as Microsoft word can open a txt file, but then warns when you try to save it that 'some features/formatting can't be saved in text format'.  It's not that hard to add, but it would go outside the scope of this proposal.  This could be a good feature though and solve a lot of user confusion.  If we were to do it, we'd list in the warning dialog what would be lost. 
 
 
{{Proposal}}
 

Revision as of 15:30, 7 November 2013