Withdrawn: Proposal Rename "Snap To"
|Proposal pages help us get from feature requests into actual plans. This page is a proposal to rename the "Snap To" function|
Proposal pages are used on an ongoing basis by the Audacity development team and are open to edits from visitors to the wiki. They are a good way to get community feedback on a proposal.
- Note: Proposals for Google Summer of Code projects are significantly different in structure, are submitted via Google's web app and may or may not have a corresponding proposal page.
We have two different "Snap To " functions in Audacity
- Time format snapping - currently identified as "Snap To" in Audacity
- Location snapping - currently identified as "Snap-to Guides" in the 2.0.3 Manual, but renamed to "Boundary Snap Guides" in the 2.0.4 alpha Manual.
The revised nomenclature for the location snapping was introduced in the 2.0.4 Manual as an attempt to provide some differentiation, however there is still room in the Manual (and in the perceptions of users) for confusion between to two distinct types of snapping in Audacity.
Following discussions on the Manual email list Gale has proposed that we rename "Snap To" (the time format snapping) to "Time Snap".
Gale wrote: " ... any name change should be as unambiguous as possible."
Alternative nomenclature suggestions
Peter's original suggestion was "Align With".
- I now withdraw that as I believe any changed nomenclature should contain the word "Snap".
Steve suggested "Selection Snap" (and moving the snap to the right end of the Selection Toolbar).
- Gale: -1
- Peter: +1 for "Time Snap"
- Gale: +1 for "Time Snap"
Making this change should involve only a simple rename of the display in the GUI and some straightforward update work in the Manual.
Find all "Snap To", Match case, Whole word, Subfolders, Find Results 1, "Entire Solution", "*.cpp;*.h"
src\Menus.cpp(1577): c->AddCommand(wxT("SnapToOn"), _("Snap To On"), FN(OnSnapToOn)); src\Menus.cpp(1578): c->AddCommand(wxT("SnapToOff"), _("Snap To Off"), FN(OnSnapToOff)); src\Project.h(309): // Snap To src\toolbars\SelectionBar.cpp(233): mSnapTo = new wxCheckBox(this, OnSnapToID, _("Snap To"), src\toolbars\SelectionBar.cpp(238): mSnapTo->SetName(_("Snap To")); Matching lines: 5 Matching files: 3 Total files searched: 792
It looks like we should change all five of these.
The tooltip would not need to be changed as the current text is equally relevant to any changed nomenclature.
Steve's Selection Toolbar mockup
Previous Feature Requests relating to this proposal