Difference between revisions of "Wording"

From Audacity Wiki
Jump to: navigation, search
(suggested changes to file formats tab)
(Move done items and tidy.)
Line 8: Line 8:
 
<br><br>
 
<br><br>
  
=Summary=
+
=Outside the program itself=
* Tweak all wording of built-in 'innertext:' help in file HelpText.cpp, including:
+
 
** [GA] adding some help text for export
 
** [GA] add text to 'innertext:recording' page about enabling monitoring.
 
** [GA] In inner text for unsupported file format, remove reference to FLAC being unsupported.<font color="green"> Draft submitted to devel-list to cover these three items</font>
 
 
 
* [RA] Update the  
 
* [RA] Update the  
 
{{external|1=[http://audacity.cvs.sourceforge.net/audacity/audacity-src/help/audacity.1?revision=1.4.2.1&view=markup Unix manual page]}} to distinguish between 1.3 and 1.2. In particular, remove reference to 1.3 importing multiple files from command line into the same Project, unless fixed before release (See [[Release Checklist#Aim to|Aim to]] for details).     
 
{{external|1=[http://audacity.cvs.sourceforge.net/audacity/audacity-src/help/audacity.1?revision=1.4.2.1&view=markup Unix manual page]}} to distinguish between 1.3 and 1.2. In particular, remove reference to 1.3 importing multiple files from command line into the same Project, unless fixed before release (See [[Release Checklist#Aim to|Aim to]] for details).     
 
* Release note for loss of second imported track in Project after crash or loss of entire Project if second track is edited.  Unless this is fixed before release.
 
* Release note for loss of second imported track in Project after crash or loss of entire Project if second track is edited.  Unless this is fixed before release.
 
 
=Innertext:Editing=
 
 
'''Currently'''
 
 
<blockquote>
 
Editing: Audacity is a powerful editor, so you'll want to see what it can do with your imported file or recording. The main commands you will use are under the Edit menu (such as cut, copy and paste) and under the Effect menu (you can do things like boost the bass, change pitch or tempo, or remove noise). <BR><BR>
 
 
Audacity applies edits to areas of the audio track. You can select a particular area of audio by clicking in the track and dragging the shaded area with your mouse. If you don't select any audio, Audacity will select all that you have on the screen.  <BR><BR>
 
 
Two important points when editing:
 
(1) If you're still playing or recording, use
 
the yellow Stop button, because you can't edit or export a moving track!
 
(2) On occasion, some of the menus or buttons are greyed out or say
 
\"Disabled\" -  this is normal. For example, because you can't edit audio while playing or recording, we grey out or disable commands until you press Stop. Commands can sometimes be unavailable for other reasons - for example you can't run effects until you have audio on the screen, and you obviously can't paste audio until you've cut or copied it to Audacity's clipboard.
 
ToWelcome()
 
</blockquote>
 
 
'''Suggested change/replacement'''
 
 
<font color = "green">
 
*The section should be called "Editing and Greyed out Menus" instead of "Greyed Out Items" - otherwise, OK as is?? - GA </font>
 
 
 
 
=Innertext:Export=
 
 
'''Currently'''
 
 
<blockquote>
 
Exporting and Saving. have different purposes. You " save" an Audacity project file when you want to return to your work in Audacity later. This means you don't then have to re-import or re-record audio, or redo editing you have done so far. When you want to listen to your work in other computer programs or burn it to CD, you "export" it as an audio file such as a WAV, AIFF or MP3.
 
To save an Audacity project, use File > Save Project. This will save an .aup Project file, plus a _data folder containing the actual audio. Make sure you don't rename or move either of these, because Audacity needs to refer to both. Only use File > Save Project As. when you either need to save an empty Project, or if you want to save an existing Project to a new name. When you want to re-open a saved Project, simply click File > Open and open the .aup file.
 
<br><br>
 
When you want to export your work to an audio file, use File > Export and choose your desired format in the "Save as type" dropdown. Click the Options button for advanced choices, such as the bit rate to use for MP3 export. There are two other Export commands under the File menu. "Export Selection" exports only a selected area of audio. "Export Multiple" exports multiple files, for example where you have more than one track on screen and want to export each as a separate file.
 
<br><br>
 
Before you can export as MP3, you need to add the LAME MP3 encoder to your computer. For help with LAME, see Lame_Installation. There is also some help on how to burn to a CD.
 
<br><br>
 
Back to Welcome page.
 
<br><br>
 
</blockquote>
 
 
'''Suggested replacement'''
 
 
*Remove superfluous "." from "Exporting and Saving. have different purposes"
 
 
*Remove superfluous space from "You " save" an Audacity project file"
 
 
*Add two dots after "As." in "Only use File > Save Project As."
 
 
 
Otherwise, OK as is?  JC
 
 
 
 
=Innertext:Recording=
 
 
'''Currently'''
 
 
<blockquote>
 
 
Back to Welcome page.
 
<br><br>
 
To start recording, press the red Record button. Before doing so however, there are three crucial settings you must check:
 
<br><br>
 
(1) The Recording Device, set in the Audio I/O tab of Preferences. By default Audacity will use the current system device, which is usually your inbuilt sound device, so you may not need to set this. But if you're using an external USB or Firewire device such as a USB turntable, make sure this device is selected as your recording device.
 
<br><br>
 
(2) The input source for your device, such as microphone or line-in.
 
 
* On Windows, you normally choose your input in the dropdown selector on the right of the Mixer Toolbar note: on Vista, you must do so at Recording Device on the Audio I/O Preferences tab.
 
* On a Mac, you normally choose input sources outside Audacity, in Apple Audio-MIDI Setup. Note: many USB or Firewire devices don't have a choice of inputs, so you can ignore this step - see the documentation for your device.
 
<br><br>
 
(3) Input volume. Before recording for real, make a test recording to set the input level, so that it's neither too soft or too loud. To do this:
 
<br><br>
 
1. Turn on monitoring, by either double-clicking over the right-hand of the two VU Meters, or right-clicking over it and choosing "Start Monitoring". If you do not see the meters, click View > Toolbars and check "Meter Toolbar".
 
<br><br>
 
2. Press Record, and adjust the input volume slider on the Mixer Toolbar (by the microphone symbol), so that the red bars in the meter come close to (but do not touch) the right edge of the scale. If you can't hear the sound, go to the Audio I/O tab of Preferences and check "Software Playthrough".
 
<br><br>
 
There is more help if you're stuck: our Recording FAQs, our Tutorial Your First Recording in the Manual, and our Wiki Recording Tips, especially the [[Troubleshooting Recordings]] section.
 
<br><br>
 
Back to Welcome page.
 
<br><br>
 
</blockquote>
 
 
'''Suggested replacement'''
 
 
OK as is?  JC
 
 
  
 
= Preferences =
 
= Preferences =
Line 122: Line 30:
 
==Batch tab==
 
==Batch tab==
  
'''Normalize on load'''
+
'''Current Text:'''
 +
 
 +
"When importing audio, normalize all tracks" (n.b. doesn't really belong on batch tab)
 +
 
 +
What this option does is to normalise any imported track to the current normalise level set at Effect > Normalize (whether or not done as part of a batch process) and additionally, normalise any other audio tracks already on screen. It doesn't normalise audio tracks on screen when you apply a chain to the current project, which it's possible users might have interpreted it as doing.
  
It was agreed this was poorly described and in the wrong place. What this does is to normalise any imported track to the current normalise level set at Effect > Normalize (whether or not done as part of a batch process) and additionally, normalise any other audio tracks already on screen. It doesn't normalise audio tracks on screen when you apply a chain to the current project, which it's possible users might have interpreted it as doing. After discussion between GA and JC, it was agreed as an interim measure to change the wording to:  
+
<font color="green">GA has slight reservation on the current wording that it may be unclear to a user who is only thinking of importing into an empty project. As we will have space, and to be consistent with the other text on the file tab:</font>
  
"When importing audio, normalize all tracks"
+
'''Suggested replacement:'''
  
This change has been made. It was further agreed to move this option into the "File Formats" tab after it has been renamed (see [[Wording#File_Formats_tab|File Formats tab]]) ; and to consider a change after 1.4 so that only one normalisation is done where you have a chain including that effect and "normalize" is turned on (this has been placed in "not aiming").
+
"When importing audio files, normalize all tracks in project" (and move this to renamed file tab)
  
GA believes these are good moves and that "normalize all tracks" will be used when it is in an appropriate tab and clearer what it does.  
+
This option should move into the "File Formats" tab after that tab has been renamed, see [[Wording#File_Formats_tab|File Formats tab]] for more.  The items in this tab have more space for text, so a longer more explanatory string is possible.  Also consider a change after 1.4 so that only one normalisation is done where you have a chain starting with that effect and "normalize" is turned on (this has been placed in "not aiming").  
  
 +
<font color="green">GA believes these are good moves and that "normalize all tracks" will be used when it is in an appropriate tab and clearer what it does.
  
 +
I suggest this would look best as the first option in the file tab. </font>
  
 
----
 
----
  
'''Show MP3-ID3 Dialog'''
+
'''Current text:'''
 +
 
 +
"Show MP3-ID3 Dialog"
  
 
The dialogue now appears for all valid formats (FLAC, WAV etc.), so...   
 
The dialogue now appears for all valid formats (FLAC, WAV etc.), so...   
Line 143: Line 59:
  
 
"Show Metadata Editor prior to export step"
 
"Show Metadata Editor prior to export step"
 
  
  
 
==Directories tab==
 
==Directories tab==
  
'''Auto save interval:'''
+
'''Current text:'''
 
 
'''Currently'''
 
  
 
"Auto save every [  ] minutes"
 
"Auto save every [  ] minutes"
  
'''Suggested replacement'''
+
'''Suggested replacement:'''
  
 
None if [MM] changes autosave to strict interval saving as per aim-to. Wording needs changing if strict interval saving not implemented. Suggested would be "Auto Save interval" (fudge).
 
None if [MM] changes autosave to strict interval saving as per aim-to. Wording needs changing if strict interval saving not implemented. Suggested would be "Auto Save interval" (fudge).
Line 161: Line 74:
 
==File Formats tab==
 
==File Formats tab==
  
'''Problem:'''  
+
'''Problem with Tab name:'''  
  
 
Since the exporting options for formats were removed from here, the tab description is no longer clear as to what it contains, and suggests it contains what it does not.
 
Since the exporting options for formats were removed from here, the tab description is no longer clear as to what it contains, and suggests it contains what it does not.
 
 
  
'''Suggested solution:'''
+
'''Suggested replacement:'''  
 
 
'''Rename the tab.'''  
 
  
 
GA: No solution is ideal due to the disparate nature of what's in there. "Export & Import" is one possibility except that does not really cover the dependencies option. I have three renaming suggestions:
 
GA: No solution is ideal due to the disparate nature of what's in there. "Export & Import" is one possibility except that does not really cover the dependencies option. I have three renaming suggestions:
  
'''1: "File Behaviors"''' or '''2: "Audio Files''' or '''3: "Files"'''
+
# "File Behaviors" or  
 +
# "Audio Files"
 +
# "Files"
  
 
In any of these three cases I have these additional suggestions:
 
In any of these three cases I have these additional suggestions:
 
  
 
'''New text, moved in from Batch tab:'''
 
'''New text, moved in from Batch tab:'''
Line 181: Line 92:
 
"When importing audio, normalize all tracks"
 
"When importing audio, normalize all tracks"
  
<font color="green"> JC agrees to its presence in this tab with this wording. GA has slight reservation on the wording that it may be unclear to a user who is only thinking of importing into an empty project. As we have space, and to be consistent with the other text here, I suggest:
+
See explanation in batch tab section.   
 
 
"When importing audio files, normalize all tracks in project"  
 
 
 
I suggest this would look best as the first option in the tab. </font>
 
 
 
  
 
'''Current text:'''
 
'''Current text:'''
Line 196: Line 102:
 
"When importing uncompressed audio files"
 
"When importing uncompressed audio files"
  
(JC agrees to this)
+
Yes - JC, GA.
  
  
Line 226: Line 132:
 
<font color="green"> Just re-emphasizes saving/export distinction but am prepared for it to be considered verbiage.</font>
 
<font color="green"> Just re-emphasizes saving/export distinction but am prepared for it to be considered verbiage.</font>
  
 +
'''Current Text:''' 
  
'''Suggested change:''' 
+
"MP3 Export Setup"
 
 
'''MP3 Export Setup'''
 
  
 
Especially with the proposed renaming of this tab, I think this should be moved into Directories tab and renamed to:  
 
Especially with the proposed renaming of this tab, I think this should be moved into Directories tab and renamed to:  
 +
 +
'''Suggested change:'''
  
 
"MP3 Export Library Location"
 
"MP3 Export Library Location"
Line 238: Line 145:
  
  
'''Suggested change:'''   
+
'''Suggested additional text:'''   
  
 
Significant numbers of users have reported difficulty finding the new location of file format export options. Whilst "when exporting tracks" needs to remain here instead of in the Export File dialogue where it should be, I suggest adding text explaining where the export options have gone to. I suggest this could go inside the "when exporting tracks" panel under the radio buttons, and say:
 
Significant numbers of users have reported difficulty finding the new location of file format export options. Whilst "when exporting tracks" needs to remain here instead of in the Export File dialogue where it should be, I suggest adding text explaining where the export options have gone to. I suggest this could go inside the "when exporting tracks" panel under the radio buttons, and say:
  
 
"Note: Export quality options for WAV, AIFF, MP3 and other formats can be chosen by clicking the Options button at time of export."   
 
"Note: Export quality options for WAV, AIFF, MP3 and other formats can be chosen by clicking the Options button at time of export."   
 
+
     
 
  
  
Line 258: Line 164:
  
 
"Enable dragging of left and right selection edges"
 
"Enable dragging of left and right selection edges"
 
  
 
'''Current text:'''
 
'''Current text:'''
Line 269: Line 174:
  
 
<font color = "green"> Is this a screen reader function, not anything that appears visually? Or what does this do and is there a better description we can make? - GA </font>
 
<font color = "green"> Is this a screen reader function, not anything that appears visually? Or what does this do and is there a better description we can make? - GA </font>
 
  
  
 
=Done=
 
=Done=
 +
 +
* '''Normalize on Load''' changed to '''When importing audio, normalize all tracks'''.
 +
----
 +
* '''Innertext:Recording''' written and text on monitoring added
 +
----
 +
* '''Innertext:Export''' written and three typos corrected.
 +
----
 +
* '''Innertext:Editing''' written and title changed to 'Editing and Greyed out Menus'.
 +
----
  
 
*'''Save Changes? Dialogue with empty Project''': changed from "\n\nSaved project will be empty!!\n\nTo save the tracks you previously\nhad, click cancel, restore the tracks\nusing undo, and then save." to "\n\nSaved project will be empty!!\n\nTo save the tracks that were previously\nopen, click Cancel, Edit > Undo until all your\ntracks are open, then File > Save Project."
 
*'''Save Changes? Dialogue with empty Project''': changed from "\n\nSaved project will be empty!!\n\nTo save the tracks you previously\nhad, click cancel, restore the tracks\nusing undo, and then save." to "\n\nSaved project will be empty!!\n\nTo save the tracks that were previously\nopen, click Cancel, Edit > Undo until all your\ntracks are open, then File > Save Project."

Revision as of 11:26, 21 October 2007




Outside the program itself

  • [RA] Update the

Unix manual page  to distinguish between 1.3 and 1.2. In particular, remove reference to 1.3 importing multiple files from command line into the same Project, unless fixed before release (See Aim to for details).

  • Release note for loss of second imported track in Project after crash or loss of entire Project if second track is edited. Unless this is fixed before release.

Preferences

Audio I/O tab

Latency panel:

Ideally this needs a few helpful words, but there is little space. Is it essential we keep the panels of equal height? If it is, then how about adding after "milliseconds":

Audio to buffer: - "higher = more latency"

Latency correction: - "negative = backwards"

If we can make more space, then we could elaborate: "higher value = more latency but more reliable recording" ; "Applies when playing tracks whilst recording. Negative value shifts recording backwards." Of course this is a substitute until we have context-sensitive help. - GA

Batch tab

Current Text:

"When importing audio, normalize all tracks" (n.b. doesn't really belong on batch tab)

What this option does is to normalise any imported track to the current normalise level set at Effect > Normalize (whether or not done as part of a batch process) and additionally, normalise any other audio tracks already on screen. It doesn't normalise audio tracks on screen when you apply a chain to the current project, which it's possible users might have interpreted it as doing.

GA has slight reservation on the current wording that it may be unclear to a user who is only thinking of importing into an empty project. As we will have space, and to be consistent with the other text on the file tab:

Suggested replacement:

"When importing audio files, normalize all tracks in project" (and move this to renamed file tab)

This option should move into the "File Formats" tab after that tab has been renamed, see File Formats tab for more. The items in this tab have more space for text, so a longer more explanatory string is possible. Also consider a change after 1.4 so that only one normalisation is done where you have a chain starting with that effect and "normalize" is turned on (this has been placed in "not aiming").

GA believes these are good moves and that "normalize all tracks" will be used when it is in an appropriate tab and clearer what it does.

I suggest this would look best as the first option in the file tab.


Current text:

"Show MP3-ID3 Dialog"

The dialogue now appears for all valid formats (FLAC, WAV etc.), so...

Suggested replacement:

"Show Metadata Editor prior to export step"


Directories tab

Current text:

"Auto save every [ ] minutes"

Suggested replacement:

None if [MM] changes autosave to strict interval saving as per aim-to. Wording needs changing if strict interval saving not implemented. Suggested would be "Auto Save interval" (fudge).


File Formats tab

Problem with Tab name:

Since the exporting options for formats were removed from here, the tab description is no longer clear as to what it contains, and suggests it contains what it does not.

Suggested replacement:

GA: No solution is ideal due to the disparate nature of what's in there. "Export & Import" is one possibility except that does not really cover the dependencies option. I have three renaming suggestions:

  1. "File Behaviors" or
  2. "Audio Files"
  3. "Files"

In any of these three cases I have these additional suggestions:

New text, moved in from Batch tab:

"When importing audio, normalize all tracks"

See explanation in batch tab section.

Current text:

"When importing uncompressed audio files into Audacity"

Suggested replacement:

"When importing uncompressed audio files"

Yes - JC, GA.


Current wording and order:

"When saving a project that depends on other audio files"

[*] Ask user

  • Always copy all audio (safest)
  • Never copy any audio

Suggested change:

  • Always copy all audio into project (safest)
  • Do not copy any audio

[*] Ask user

GA thinks this does not read well with "Ask user" at top - you have to look further down to see what you are being asked. This change will also match the "importing" option by having the safe option at the top. "Do not copy any audio" is the new standard button text. It may not be better here than "Never copy any audio", but I think it's worth asking.


Current text:

"When exporting tracks"

Suggested change:

"When exporting tracks to an audio file"

Just re-emphasizes saving/export distinction but am prepared for it to be considered verbiage.

Current Text:

"MP3 Export Setup"

Especially with the proposed renaming of this tab, I think this should be moved into Directories tab and renamed to:

Suggested change:

"MP3 Export Library Location"

which is what it actually is.


Suggested additional text:

Significant numbers of users have reported difficulty finding the new location of file format export options. Whilst "when exporting tracks" needs to remain here instead of in the Export File dialogue where it should be, I suggest adding text explaining where the export options have gone to. I suggest this could go inside the "when exporting tracks" panel under the radio buttons, and say:

"Note: Export quality options for WAV, AIFF, MP3 and other formats can be chosen by clicking the Options button at time of export."


Interface tab

Behaviours:

Current text:

"Dragging of left and right selection edges"

Suggested replacement:

"Enable dragging of left and right selection edges"

Current text:

"Present track number to accessibility aid"

Suggested replacement:

"Present track number as accessibility aid"

Is this a screen reader function, not anything that appears visually? Or what does this do and is there a better description we can make? - GA


Done

  • Normalize on Load changed to When importing audio, normalize all tracks.

  • Innertext:Recording written and text on monitoring added

  • Innertext:Export written and three typos corrected.

  • Innertext:Editing written and title changed to 'Editing and Greyed out Menus'.

  • Save Changes? Dialogue with empty Project: changed from "\n\nSaved project will be empty!!\n\nTo save the tracks you previously\nhad, click cancel, restore the tracks\nusing undo, and then save." to "\n\nSaved project will be empty!!\n\nTo save the tracks that were previously\nopen, click Cancel, Edit > Undo until all your\ntracks are open, then File > Save Project."

  • Interface tab, Show/Hide: "Show Welcome Message at program start up" , was 'Splash Screen'.

  • Find Clipping: "Start and stop must be greater than 0", was 'positive and greater than zero'.

  • Dependencies dialogue: The former "Close" and "Skip" buttons now both read "Do not copy any audio".

  • Export Multiple progress dialogue: "Exporting the entire project as a WAV/AIFF file" or (for MP3) "exporting the entire file..." now changed to "Exporting entire project" with (filename) in the dialogue title and (format) above the progress bar.

  • Latency Shift Dialogue: In "I have brought it back to start at zero", "I have" has been replaced with "Audacity has".

  • Preferences: Interface tab: "Tracks &fit vertically zoomed" changed to "Automatically &fit tracks vertically zoomed"

  • "Audacious!" buttons -> "OK... Audacious!"

  • GUIPrefs.CPP:

- "&Select all audio, if none selected, on applying effect"

+ "&Select all audio in project, if none selected"

- "&Circular track keyboard navigation"

+ "\"Move track focus\" &cycles repeatedly through tracks"

- "&Quit Audacity upon closing last window"

+ "Any Close/Exit command completely &quits Audacity"


  • Import.CPP:

- " is an encrypted audio file, typically from an online music store. \nAudacity cannot open this type of file due to the encryption.\nYou need to convert it to a supported, unencrypted audio format."

+ " is an encrypted audio file. These typically are from an online music store. \nAudacity cannot open this type of file due to the encryption. \nTry recording the file into Audacity, or burn it to audio CD then \nextract the CD track to a supported audio format such as WAV or AIFF."

- " is an audio CD file. \nAudacity does not open this type of file.\nTry ripping it to a native audio format that Audacity can import."

+ " is an audio CD track. \nAudacity cannot open audio CDs directly. \nExtract (rip) the CD tracks to an audio format that \nAudacity can import, such as WAV or AIFF.");

Add "WAV or AIFF" references to Real, AAC and WMA:

- " is a RealPlayer media file. \nAudacity cannot open this..."

+ " is a RealPlayer media file. \nAudacity cannot open this proprietary format. \nYou need to convert it to a supported audio format, such as WAV or AIFF."

- " is an Advanced Audio Coding file. \nAudacity cannot open this..."

+ " is an Advanced Audio Coding file. \nAudacity cannot open this type of file. \nYou need to convert it to a supported audio format, such as WAV or AIFF."

- " is a Windows Media Audio file. \nAudacity cannot open this..."

+ " is a Windows Media Audio file. \nAudacity cannot open this type of file due to patent restrictions. \nYou need to convert it to a supported audio format, such as WAV or AIFF."



  • Default temporary directory: changed from "/tmp/audacity1.2-%USERNAME" to AUDACITY_VERSION, AUDACITY_RELEASE string