Wording

From Audacity Wiki
Revision as of 22:39, 20 October 2007 by Galeandrews (talk | contribs) (Batch tab: are we geting there?)
Jump to: navigation, search




Summary

  • Tweak all wording of built-in 'innertext:' help in file HelpText.cpp, including:
    • [GA] adding some help text for export
    • [GA] add text to 'innertext:recording' page about enabling monitoring.
    • [GA] In inner text for unsupported file format, remove reference to FLAC being unsupported. Draft submitted to devel-list to cover these three items
  • [RA] Update the Unix manual page  to distinguish between 1.3 and 1.2. In particular, remove reference to 1.3 importing multiple files from command line into the same Project, unless fixed before release (See Aim to for details).
  • Release note for loss of second imported track in Project after crash or loss of entire Project if second track is edited. Unless this is fixed before release.


Innertext:Editing

Currently

Editing: Audacity is a powerful editor, so you'll want to see what it can do with your imported file or recording. The main commands you will use are under the Edit menu (such as cut, copy and paste) and under the Effect menu (you can do things like boost the bass, change pitch or tempo, or remove noise).

Audacity applies edits to areas of the audio track. You can select a particular area of audio by clicking in the track and dragging the shaded area with your mouse. If you don't select any audio, Audacity will select all that you have on the screen.

Two important points when editing: (1) If you're still playing or recording, use the yellow Stop button, because you can't edit or export a moving track! (2) On occasion, some of the menus or buttons are greyed out or say \"Disabled\" - this is normal. For example, because you can't edit audio while playing or recording, we grey out or disable commands until you press Stop. Commands can sometimes be unavailable for other reasons - for example you can't run effects until you have audio on the screen, and you obviously can't paste audio until you've cut or copied it to Audacity's clipboard. ToWelcome()

Suggested change/replacement

  • The section should be called "Editing and Greyed out Menus" instead of "Greyed Out Items" - otherwise, OK as is?? - GA


Innertext:Export

Currently

Exporting and Saving. have different purposes. You " save" an Audacity project file when you want to return to your work in Audacity later. This means you don't then have to re-import or re-record audio, or redo editing you have done so far. When you want to listen to your work in other computer programs or burn it to CD, you "export" it as an audio file such as a WAV, AIFF or MP3. To save an Audacity project, use File > Save Project. This will save an .aup Project file, plus a _data folder containing the actual audio. Make sure you don't rename or move either of these, because Audacity needs to refer to both. Only use File > Save Project As. when you either need to save an empty Project, or if you want to save an existing Project to a new name. When you want to re-open a saved Project, simply click File > Open and open the .aup file.

When you want to export your work to an audio file, use File > Export and choose your desired format in the "Save as type" dropdown. Click the Options button for advanced choices, such as the bit rate to use for MP3 export. There are two other Export commands under the File menu. "Export Selection" exports only a selected area of audio. "Export Multiple" exports multiple files, for example where you have more than one track on screen and want to export each as a separate file.

Before you can export as MP3, you need to add the LAME MP3 encoder to your computer. For help with LAME, see Lame_Installation. There is also some help on how to burn to a CD.

Back to Welcome page.

Suggested replacement

  • Remove superfluous "." from "Exporting and Saving. have different purposes"
  • Remove superfluous space from "You " save" an Audacity project file"
  • Add two dots after "As." in "Only use File > Save Project As."


Otherwise, OK as is? JC


Innertext:Recording

Currently

Back to Welcome page.

To start recording, press the red Record button. Before doing so however, there are three crucial settings you must check:

(1) The Recording Device, set in the Audio I/O tab of Preferences. By default Audacity will use the current system device, which is usually your inbuilt sound device, so you may not need to set this. But if you're using an external USB or Firewire device such as a USB turntable, make sure this device is selected as your recording device.

(2) The input source for your device, such as microphone or line-in.

  • On Windows, you normally choose your input in the dropdown selector on the right of the Mixer Toolbar note: on Vista, you must do so at Recording Device on the Audio I/O Preferences tab.
  • On a Mac, you normally choose input sources outside Audacity, in Apple Audio-MIDI Setup. Note: many USB or Firewire devices don't have a choice of inputs, so you can ignore this step - see the documentation for your device.



(3) Input volume. Before recording for real, make a test recording to set the input level, so that it's neither too soft or too loud. To do this:

1. Turn on monitoring, by either double-clicking over the right-hand of the two VU Meters, or right-clicking over it and choosing "Start Monitoring". If you do not see the meters, click View > Toolbars and check "Meter Toolbar".

2. Press Record, and adjust the input volume slider on the Mixer Toolbar (by the microphone symbol), so that the red bars in the meter come close to (but do not touch) the right edge of the scale. If you can't hear the sound, go to the Audio I/O tab of Preferences and check "Software Playthrough".

There is more help if you're stuck: our Recording FAQs, our Tutorial Your First Recording in the Manual, and our Wiki Recording Tips, especially the Troubleshooting Recordings section.

Back to Welcome page.

Suggested replacement

OK as is? JC


Preferences

Audio I/O tab

Latency panel:

Ideally this needs a few helpful words, but there is little space. Is it essential we keep the panels of equal height? If it is, then how about adding after "milliseconds":

Audio to buffer: - "higher = more latency"

Latency correction: - "negative = backwards"

If we can make more space, then we could elaborate: "higher value = more latency but more reliable recording" ; "Applies when playing tracks whilst recording. Negative value shifts recording backwards." Of course this is a substitute until we have context-sensitive help. - GA

Batch tab

Normalize on load

GA: This is poorly described and in the wrong place. What this actually does is to normalise any imported track to the current normalise level set at Effect > Normalize (whether or not done as part of a batch process) and additionally, normalise any other audio tracks already on screen. However it doesn't normalise audio tracks on screen when you apply a chain to the current project, which it's possible users might interpret it as.

Suggested change:

Move from Batch tab to File Formats tab. Change description to:

"When importing audio files, normalize these and existing tracks to current Effect > Normalize level"

or simpler (but worse?):

"When importing audio files, normalize these and existing tracks to current normalization level"


GA: Additionally, should normalise on load apply when importing files for batch processing? Currently, if you have this preference enabled, and have a normalise step in the chain, normalise is done twice. If it's thought desirable to disallow this preference for chains, this will have to move to Release Checklist or not aiming for 1.4 as it will be a programming change.

JC: I'm inclined to drop this option entirely. In batch chains we get the effect by adding a normalize step into the chain. How useful is it really in other cases? How would a newbie user discover how to turn it off?

GA: Normalize on load is off by default so a novice wouldn't see it. I do think in fact this is a useful feature for other than chains and has been requested in the past. It is quite common I think that you'd want to normalise but not do other things that might justify running a chain, or normalise and then edit, for which chains don't currently give you a full range of options and probably never will. It ought to be more discoverable by being in another tab, and arguably could have a sub-option as to whether or not existing tracks are also normalized. So is the sensible thing to remove it from Prefs. entirely for now, and develop this after 1.4 so that it doesn't apply to chains?

JC: If it's been requested, I guess we should keep it for now, even though I think it is of low utility/confusing. We can live with having normalize applied twice. Possibly later we can make normalize faster (do nothing) when already normalized. Your wording is WAY too long. It's not a file format option. If anything it's a Gui behaviour preference. I agree it is badly placed and could be more explanatory, but I think what you propose is not an improvement, so it should stay as is unless there is a better (shorter) suggestion.

GA: My thought is that it is far more like a File Format option than an Interface option (note: File Formats is probably a misnomer - only the MP3 section is solely to do with File Formats, and the section should far better be called "Import/Export" or similar which would give us more flexibility - would you agree?). On the basis it might move to "File Formats", the suggested wording was actually designed to be like others in that section, so that's why it was long. Exactly because this option may be confusing, we need to explain what it does, and it's near-meaningless as it stands unless you know what it does in the first place. I never had time before now to work out exactly what it actually does and doesn't do, and until I had done so, I couldn't suggest an improvement.

So how about:

"Normalise imported files along with existing tracks"

or "together with" or "and any" in place of "along with".

If you only want five or six words, I can't see an easy way of explaining that you will actually get the normalisation you set at Effect > Normalize. If you have a suggestion yourself how to do that with so few words, please make it. As always, in my book longer, good descriptions are better than shorter ones if short ones can't convey the point. I'm sure the above is far better than what we have now, even if you think it should go on the Interface tab.

JC: "When importing audio, normalize all tracks" ?

GA: I'm fine with that in order to agree, and it's good, and elegant, though for someone who isn't thinking along the lines of having tracks in situ already (say an import > trim > fades > export job), I'd suggest it doesn't convey it quite as well or quickly as mine e.g. it "might" make them wonder if we mean normalising both channels of their imported audio, or all the files (if they are multiple importing)?

Where would you like it to go? My vote is to change "File Formats" to something more descriptive in any case, and to put this in there. If it goes in a renamed "File Formats" tab, I'd also suggest that in that tab, we remove "into Audacity" from "When importing uncompressed audio files into Audacity". Then as you say we can consider a change after 1.4 so that only one normalisation is done if you have a chain including that effect.



Show MP3-ID3 Dialog

The dialogue now appears for all valid formats (FLAC, WAV etc.), so...

Suggested replacement:

"Show Metadata Editor prior to export step"

Directories tab

Auto save interval:

Currently

"Auto save every [ ] minutes"

Suggested replacement

None if [MM] changes autosave to strict interval saving as per aim-to. Wording needs changing if strict interval saving not implemented. Suggested would be "Auto Save interval" (fudge).


Interface tab

Behaviours:

Current text:

"Dragging of left and right selection edges"

Suggested replacement:

"Enable dragging of left and right selection edges"


Current text:

"Present track number to accessibility aid"

Suggested replacement:

"Present track number as accessibility aid"

Is this a screen reader function, not anything that appears visually? Or what does this do and is there a better description we can make? - GA


Done

  • Save Changes? Dialogue with empty Project: changed from "\n\nSaved project will be empty!!\n\nTo save the tracks you previously\nhad, click cancel, restore the tracks\nusing undo, and then save." to "\n\nSaved project will be empty!!\n\nTo save the tracks that were previously\nopen, click Cancel, Edit > Undo until all your\ntracks are open, then File > Save Project."

  • Interface tab, Show/Hide: "Show Welcome Message at program start up" , was 'Splash Screen'.

  • Find Clipping: "Start and stop must be greater than 0", was 'positive and greater than zero'.

  • Dependencies dialogue: The former "Close" and "Skip" buttons now both read "Do not copy any audio".

  • Export Multiple progress dialogue: "Exporting the entire project as a WAV/AIFF file" or (for MP3) "exporting the entire file..." now changed to "Exporting entire project" with (filename) in the dialogue title and (format) above the progress bar.

  • Latency Shift Dialogue: In "I have brought it back to start at zero", "I have" has been replaced with "Audacity has".

  • Preferences: Interface tab: "Tracks &fit vertically zoomed" changed to "Automatically &fit tracks vertically zoomed"

  • "Audacious!" buttons -> "OK... Audacious!"

  • GUIPrefs.CPP:

- "&Select all audio, if none selected, on applying effect"

+ "&Select all audio in project, if none selected"

- "&Circular track keyboard navigation"

+ "\"Move track focus\" &cycles repeatedly through tracks"

- "&Quit Audacity upon closing last window"

+ "Any Close/Exit command completely &quits Audacity"


  • Import.CPP:

- " is an encrypted audio file, typically from an online music store. \nAudacity cannot open this type of file due to the encryption.\nYou need to convert it to a supported, unencrypted audio format."

+ " is an encrypted audio file. These typically are from an online music store. \nAudacity cannot open this type of file due to the encryption. \nTry recording the file into Audacity, or burn it to audio CD then \nextract the CD track to a supported audio format such as WAV or AIFF."

- " is an audio CD file. \nAudacity does not open this type of file.\nTry ripping it to a native audio format that Audacity can import."

+ " is an audio CD track. \nAudacity cannot open audio CDs directly. \nExtract (rip) the CD tracks to an audio format that \nAudacity can import, such as WAV or AIFF.");

Add "WAV or AIFF" references to Real, AAC and WMA:

- " is a RealPlayer media file. \nAudacity cannot open this..."

+ " is a RealPlayer media file. \nAudacity cannot open this proprietary format. \nYou need to convert it to a supported audio format, such as WAV or AIFF."

- " is an Advanced Audio Coding file. \nAudacity cannot open this..."

+ " is an Advanced Audio Coding file. \nAudacity cannot open this type of file. \nYou need to convert it to a supported audio format, such as WAV or AIFF."

- " is a Windows Media Audio file. \nAudacity cannot open this..."

+ " is a Windows Media Audio file. \nAudacity cannot open this type of file due to patent restrictions. \nYou need to convert it to a supported audio format, such as WAV or AIFF."



  • Default temporary directory: changed from "/tmp/audacity1.2-%USERNAME" to AUDACITY_VERSION, AUDACITY_RELEASE string