Wording

From Audacity Wiki
Revision as of 16:48, 19 April 2016 by PeterSampson (talk | contribs) (OK... Audacious!: formatting)
Jump to: navigation, search


Warning icon Peter 19Apr16: future entries on this page should show the date they were added - then we can see how long they remain here uncompleted.


Other source code changes that may require changes in text in Audacity as a consequence do not belong here. That is, don't put a wording change here unless it is needed with the code as it is now. Changes to the GUI such as moving buttons or controls from one place to another don't belong here either because they are not just wording changes. Also, only changes to documents that are actually compiled into executable builds, such as HelpText.cpp, should be included here - all other changes go to Documentation Checklist.

I largely agree, though that does mean that (relatively trivial) wording changes (like that to the LAME download button arising from a LAME installer) would have to be done at the time by the person doing the coding, or otherwise leave them and move the item in to "Wording" after coding? - GA



Warning icon Gale Oct 2011: This is probably a good place to store "cosmetic" wording changes which are not worth breaking pre-2.0 translations for, but which should be dealt with for 2.1.0 (unless it seems a coding change is a better choice in a particular instance).


Welcome message

Current text: I've no idea of line number, sorry

" ... Internet version if it isn't"

Suggested replacement:

" ... Internet version if not"

This is in line with Gale's call long ago, on 26Nov07, for "more concise and impersonal" text in messages. One should not really use constructs like "isn't" in written form unless quoting spoken words.

OK... Audacious!

Current text: I've no idea of line number, sorry

"OK... Audacious!"

Suggested replacement:

"OK"

Gale wrote back on 26Nov07 This button is currently used in Welcome Screen and About Audacity. However, not everyone is comfortable with "Audacious" and screen reader users may be confused by lack of a simple "OK". As we apparently want to be more concise and impersonal, and avoid long buttons, it's suggested we should simply drop "Audacious" and replace it with "OK".

At some stage this was removed from the Welcome Screen. For consistency, as well as "more concise and impersonal" as Gale suggested back then, can we please change the OK... Audacious! button on the Help>About Audacity to a simple OK button.

Report added: 19Apr16 by Peter

Effects

ExportMP3.cpp

Current text: Line 578

"To get a free copy of Lame, click here -->"

Suggested replacement:

"To install LAME for free, click here -->"

or

"To install a free copy of LAME, click here -->"

This suggestion only really makes sense in context that we have a simple SFX LAME installer for Windows (easily done) and that the Windows wording can be different to the other platforms.

It mentions below in the "Completed" section

Report added: 08Jan08

Import.cpp

Current text: Line 698

"Audacity did not recognize the type of the file '%s'. If it is uncompressed, try importing it using "Import Raw"."

Suggested replacement:

"Audacity did not recognize the type of the file '%s'. If it is uncompressed, try importing it at File > Import > Raw Data."

or (requires coding):

"Audacity did not recognize the type of the file '%s'. If it is uncompressed, you can try importing it as Raw Data.

Import file as Raw Data now?
[Yes] [No] [Help]

Gale: Second option is clearly more user-friendly but either is an improvement


Preferences

Recording tab

Current Text:

"Software Playthrough: Listen while recording or monitoring new track

(uncheck when recording "stereo mix")"

Suggested replacement:

"Software Playthrough: Listen to input while recording or monitoring

(uncheck when recording "stereo mix")"

or:

"Software Playthrough: Listen while recording or monitoring

(uncheck when recording "stereo mix")"

Gale: There is no new track if monitoring without recording.

Report added: 31Aug2008

Sequence.cpp

Current text:

  • line 1041: "Sequence has block file with length %s > mMaxSamples %s.\nTruncating to mMaxSamples."

Suggested replacement:

  • "Sequence has block file exceeding maximum number of samples per block.\nTruncating to this maximum length."

Gale and Vaughan agree on this or a similar change.

Current text:

  • line 1044: "Warning - Length in Writing Sequence"

Suggested replacement:

  • "Warning - Truncating Overlong Block File"

Gale originally suggested "Warning - Length of Written Block File" but Vaughan felt this implied it was not corrected when it was.

Report added: 04Mar2012

Done

  • "Leveller" name in interface changed to "Leveler".
  • RecordingPrefs.cpp: Add "Overdub" to read: "Overdub: Play other tracks while recording new one".
  • DirectoriesPrefs.cpp: reword audio cache preference to "Play and/or record using RAM (useful for slow drives, but could crash with long files or recordings)." Remove "AutoSave" choice.
  • TrackPanel.cpp: "Draw currently only works with linear-view waveforms" > "To use Draw, choose 'Waveform' in the Track Drop-down Menu"
  • Import / Export Preferences: Remove duplicated "When importing audio" from "Normalize all tracks in project"
  • Import.cpp: Add file type exclusions for MIDI, other notes-based formats, Musepack, Wavpack, AC3 and Speex.
  • Import.cpp: Remove exclusion of .mpa format as it's a valid MPEG-1 format.
  • Interface tab: Change to "Closing last window quits Audacity" (similar, slightly shorter wording to that in 1.3.3)
  • ExportPCM.cpp: Options dialog for "WAV, AIFF, and other uncompressed types" changed from "Specify PCM Options" to "Specify Uncompressed Options"
  • Generate Menu: change inconsistent wordings in Chirp, DTMF, Noise, Silence, Tone to "Duration:"
  • Project.cpp: change text when opening 1.x project to "This file was saved by Audacity (1.x.x), a much\nolder version. The format has changed.\nAudacity could corrupt the file in opening\nit, so you must back it up first.\n\nOpen this file now?"
  • Tracks menu > Resample: change to "New sample rate (Hz)"
  • Interface tab: change to "Display range minimum for 'waveform (dB)' view"
  • Autorecovery.cpp: change to "Confirm?" dialog header and text "Are you sure you don't want to recover any projects? They can't be recovered later."
  • Both "OK...Audacious" buttons to "OK".
  • Project.cpp: change to "This file was saved by Audacity (1.2.6). You can open\nthe file with this version of Audacity, but if you save it with this version\nyou will no longer be able to open it in older versions.\n\nOpen this file now?"
  • HelpText.cpp: remove duplicated links and make "[burnCD|burn to a CD]]" a bullet
  • Credit to Chris Cannam on the "Audacity" tab of "About Audacity" for Vamp.
  • Interface tab: remove preference "Present track number to accessibility aid"
  • MP3 Export Library Location, added under "when exporting tracks" Note: Export quality options for WAV, AIFF, MP3 and other formats can be chosen by clicking the Options button at time of export.
  • Audio to buffer: (higher = more latency)
  • Latency correction: (negative = backwards)
  • If you want to burn your work to an audio CD for standalone CD players, you must first in HelpText.cpp
  • a WAV, AIFF or MP3. If burning to an audio CD for standalone CD players, you must export as WAV or AIFF. in Helptext.cpp.
  • Enable dragging of left and right selection edges added the word 'enable'.
  • MP3 Export Setup to MP3 Export Library Location which is what it is.
  • When exporting tracks to an audio file added emphasis, 'to an audio file'.
  • When saving a project... wording for dependencies and order of options changed.
  • When importing uncompressed audio files into Audacity to When importing uncompressed audio files
  • File Formats tab name changed to Audio Files
  • HelpText.cpp many wording changes, including fix to |<< and >>|.
  • Normalize on Load changed to When importing audio, normalize all tracks.
  • Innertext:Recording written and text on monitoring added
  • Innertext:Export written and three typos corrected.
  • Innertext:Editing written and title changed to 'Editing and Greyed out Menus'.
  • Save Changes? Dialogue with empty Project: changed from "\n\nSaved project will be empty!!\n\nTo save the tracks you previously\nhad, click cancel, restore the tracks\nusing undo, and then save." to "\n\nSaved project will be empty!!\n\nTo save the tracks that were previously\nopen, click Cancel, Edit > Undo until all your\ntracks are open, then File > Save Project."
  • Interface tab, Show/Hide: "Show Welcome Message at program start up" , was 'Splash Screen'.
  • Find Clipping: "Start and stop must be greater than 0", was 'positive and greater than zero'.
  • Dependencies dialogue: The former "Close" and "Skip" buttons now both read "Do not copy any audio".
  • Export Multiple progress dialogue: "Exporting the entire project as a WAV/AIFF file" or (for MP3) "exporting the entire file..." now changed to "Exporting entire project" with (file name) in the dialogue title and (format) above the progress bar.
  • Latency Shift Dialogue: In "I have brought it back to start at zero", "I have" has been replaced with "Audacity has".
  • Preferences: Interface tab: "Tracks &fit vertically zoomed" changed to "Automatically &fit tracks vertically zoomed"
  • "Audacious!" buttons -> "OK... Audacious!"
  • GUIPrefs.CPP:

- "&Select all audio, if none selected, on applying effect"

+ "&Select all audio in project, if none selected"

- "&Circular track keyboard navigation"

+ "\"Move track focus\" &cycles repeatedly through tracks"

- "&Quit Audacity upon closing last window"

+ "Any Close/Exit command completely &quits Audacity"


  • Import.CPP:

- " is an encrypted audio file, typically from an online music store. \nAudacity cannot open this type of file due to the encryption.\nYou need to convert it to a supported, unencrypted audio format."

+ " is an encrypted audio file. These typically are from an online music store. \nAudacity cannot open this type of file due to the encryption. \nTry recording the file into Audacity, or burn it to audio CD then \nextract the CD track to a supported audio format such as WAV or AIFF."

- " is an audio CD file. \nAudacity does not open this type of file.\nTry ripping it to a native audio format that Audacity can import."

+ " is an audio CD track. \nAudacity cannot open audio CDs directly. \nExtract (rip) the CD tracks to an audio format that \nAudacity can import, such as WAV or AIFF.");

Add "WAV or AIFF" references to Real, AAC and WMA:

- " is a RealPlayer media file. \nAudacity cannot open this..."

+ " is a RealPlayer media file. \nAudacity cannot open this proprietary format. \nYou need to convert it to a supported audio format, such as WAV or AIFF."

- " is an Advanced Audio Coding file. \nAudacity cannot open this..."

+ " is an Advanced Audio Coding file. \nAudacity cannot open this type of file. \nYou need to convert it to a supported audio format, such as WAV or AIFF."

- " is a Windows Media Audio file. \nAudacity cannot open this..."

+ " is a Windows Media Audio file. \nAudacity cannot open this type of file due to patent restrictions. \nYou need to convert it to a supported audio format, such as WAV or AIFF."


  • Default temporary directory: changed from "/tmp/audacity1.2-%USERNAME" to AUDACITY_VERSION, AUDACITY_RELEASE string