Difference between revisions of "Wording"

From Audacity Wiki
Jump to: navigation, search
(Latency shift wording moved to "done")
(move completed stuff to the Done section)
Line 14: Line 14:
 
* [RA] Update the {{external|1=[http://audacity.cvs.sourceforge.net/audacity/audacity-src/help/audacity.1?revision=1.4.2.1&view=markup Unix manual page]}} to distinguish between 1.3 and 1.2. In particular, remove reference to 1.3 importing multiple files from command line into the same Project, unless fixed before release (See [[Release Checklist#Aim to|Aim to]] for details).     
 
* [RA] Update the {{external|1=[http://audacity.cvs.sourceforge.net/audacity/audacity-src/help/audacity.1?revision=1.4.2.1&view=markup Unix manual page]}} to distinguish between 1.3 and 1.2. In particular, remove reference to 1.3 importing multiple files from command line into the same Project, unless fixed before release (See [[Release Checklist#Aim to|Aim to]] for details).     
 
* Release note for loss of second imported track in Project after crash or loss of entire Project if second track is edited.  Unless this is fixed before release.
 
* Release note for loss of second imported track in Project after crash or loss of entire Project if second track is edited.  Unless this is fixed before release.
 
 
= Dependencies dialogue =
 
 
The "Project depends on other audio files" dialogue currently appears differently on the two occasions it appears. When you go File > Check Dependencies, the buttons are:
 
 
* "Copy Selected Audio Into Project"   
 
* "Copy All Audio Into Project (safer)"
 
* "Close" 
 
 
When you try to save a Project which has dependencies the buttons are:
 
 
* "Copy Selected Audio Into Project"   
 
* "Copy All Audio Into Project (safer)"
 
* "Cancel Save"
 
* "Skip" 
 
 
However the "Close" and "Skip" buttons mean the same thing (do not copy) but just lead to different actions ("do not copy" then return to GUI in the first case, "do not copy" then save with dependencies in the second).
 
Therefore the proposal is:
 
 
'''Current button text'''
 
 
"Close" and "Skip"
 
 
'''Suggested text for both buttons'''
 
 
"Do not copy any audio"
 
 
<span style="color:green; font-style:italic">This suggested text will need a slight increase in the dialogue width when saving a Project, and so to be consistent, in both dialogues. If this is undesirable, the suggested text could be shortened to "Do not copy", but GA's opinion is that the longer version is best.</span>
 
  
 
=Find Clipping=
 
=Find Clipping=
Line 208: Line 179:
  
 
* Latency Shift Dialogue: In "I have brought it back to start at zero", "I have" has been replaced with "Audacity has".  
 
* Latency Shift Dialogue: In "I have brought it back to start at zero", "I have" has been replaced with "Audacity has".  
 +
 +
= Dependencies dialogue =
 +
 +
The "Project depends on other audio files" dialogue currently appears differently on the two occasions it appears. When you go File > Check Dependencies, the buttons are:
 +
 +
* "Copy Selected Audio Into Project"   
 +
* "Copy All Audio Into Project (safer)"
 +
* "Close" 
 +
 +
When you try to save a Project which has dependencies the buttons are:
 +
 +
* "Copy Selected Audio Into Project"   
 +
* "Copy All Audio Into Project (safer)"
 +
* "Cancel Save"
 +
* "Skip" 
 +
 +
However the "Close" and "Skip" buttons mean the same thing (do not copy) but just lead to different actions ("do not copy" then return to GUI in the first case, "do not copy" then save with dependencies in the second).
 +
Therefore the proposal is:
 +
 +
'''Current button text'''
 +
 +
"Close" and "Skip"
 +
 +
'''Suggested text for both buttons'''
 +
 +
"Do not copy any audio"
 +
 +
<span style="color:green; font-style:italic">This suggested text will need a slight increase in the dialogue width when saving a Project, and so to be consistent, in both dialogues. If this is undesirable, the suggested text could be shortened to "Do not copy", but GA's opinion is that the longer version is best.</span>
 +
  
  

Revision as of 07:35, 2 October 2007

This list should only be modified by subscribers to Audacity-devel mailing list.

The list is for finalising text that appears in Audacity.

This is a companion list to the Release Checklist

This is a companion list to the Documentation Checklist

Summary

  • Tweak all wording of built-in 'innertext:' help in file HelpText.cpp, including:
    • [GA] adding some help text for export
    • [GA] add text to 'inertext:recording' page about enabling monitoring.
    • In inner text for unsupported file format, remove reference to FLAC being unsupported.
  • [RA] Update the Unix manual page  to distinguish between 1.3 and 1.2. In particular, remove reference to 1.3 importing multiple files from command line into the same Project, unless fixed before release (See Aim to for details).
  • Release note for loss of second imported track in Project after crash or loss of entire Project if second track is edited. Unless this is fixed before release.

Find Clipping

Current text:

"Start and stop must be postive and greater than 0"

Proposed replacement:

"Start and stop must be greater than 0"

Import.cpp

Audio CD warning

Current text

"(" is an audio CD file. \nAudacity does not open this type of file.\nTry ripping it to a native audio format that Audacity can import.")"

"Native" is often meaningless to novices.

Suggested replacement

"(" is an audio CD track. \nAudacity cannot open audio CDs directly.\nPlease extract the CD tracks to an audio format that Audacity can import, like WAV or AIFF.")"



WMA files warning

Current text

"(" is a Windows Media Audio file. \nAudacity cannot open this type of file to due to patent restrictions.\nYou need to convert it to a supported audio format.")"

Suggested replacement to remove typo

"(" is a Windows Media Audio file. \nAudacity cannot open this type of file due to patent restrictions.\nYou need to convert it to a supported audio format.")"



Encrypted warning

Current text

"(" is an encrypted audio file, typically from an online music store. \nAudacity cannot open this type of file due to the encryption.\nYou need to convert it to a supported, unencrypted audio format.")"

Suggested replacement

"(" is an encrypted audio file, typically from an online music store. \nAudacity cannot open this type of file due to the encryption.\nTry recording the file into Audacity, or burn it to audio CD then\n extract the CD track to a supported audio format like WAV or AIFF.")"



It would be better to standardise the other warnings, so:

Suggested replacements

(" is an Advanced Audio Coding file. \nAudacity cannot open this type of file due to patent restrictions.\nYou need to convert it to a supported audio format.")

(" is a RealPlayer file. \nAudacity cannot open this type of file due to patent restrictions. \nYou need to convert it to a supported audio format.")


Innertext:Recording

Innertext:Export

Preferences

Directories tab

Default temporary directory:

Currently

"/tmp/audacity1.2-%USERNAME"

Suggested replacement

"/tmp/audacity1.4-%USERNAME"



Auto save interval:

Currently

"Auto save every [ ] minutes"

Suggested replacement

None if [MM] changes autosave to strict interval saving as per aim-to. Wording needs changing if strict interval saving not implemented. Suggested would be "Auto Save interval" (fudge).


Interface tab Behaviors

Currently

"Quit Audacity upon closing last window"

Suggested replacement

"Closing last window starts new empty Project"

This would remove user confusion with this Preference BUT means reversing the checkbox mapping. An alternative (better than what we have now): "any close/exit command quits Audacity completely".



Currently

"Circular track keyboard navigation"

Suggested replacement

"Move Track Focus cycles perpetually through tracks"



Currently

"Tracks fit vertically zoomed"

Suggested replacement

"Auto-fit tracks vertically zoomed"



Currently

"Select all audio, if none selected, on applying effect"

Suggested replacement

"Select all audio in Project if none selected"



Save Changes? Dialogue with empty Project

Make Cancel to be the default button, not Yes (Yes as default is too dangerous). Then change text of dialogue thus:

Currently

"To save the tracks you previously had, click cancel, restore the tracks using undo, and then save"

Suggested replacement

"To save the tracks that were previously open, click Cancel (highlighted), Edit > Undo until all your tracks are open, then File > Save Project"


Done

  • Export Multiple progress dialogue: "Exporting the entire project as a WAV/AIFF file" or (for MP3) "exporting the entire file..." now changed to "Exporting entire project" with (filename) in the dialogue title and (format) above the progress bar.

  • Latency Shift Dialogue: In "I have brought it back to start at zero", "I have" has been replaced with "Audacity has".

Dependencies dialogue

The "Project depends on other audio files" dialogue currently appears differently on the two occasions it appears. When you go File > Check Dependencies, the buttons are:

  • "Copy Selected Audio Into Project"
  • "Copy All Audio Into Project (safer)"
  • "Close"

When you try to save a Project which has dependencies the buttons are:

  • "Copy Selected Audio Into Project"
  • "Copy All Audio Into Project (safer)"
  • "Cancel Save"
  • "Skip"

However the "Close" and "Skip" buttons mean the same thing (do not copy) but just lead to different actions ("do not copy" then return to GUI in the first case, "do not copy" then save with dependencies in the second). Therefore the proposal is:

Current button text

"Close" and "Skip"

Suggested text for both buttons

"Do not copy any audio"

This suggested text will need a slight increase in the dialogue width when saving a Project, and so to be consistent, in both dialogues. If this is undesirable, the suggested text could be shortened to "Do not copy", but GA's opinion is that the longer version is best.