Wording

From Audacity Wiki
Revision as of 11:41, 18 October 2007 by James (talk | contribs) (changes to reflect what's been done recently and what still needs to be done.)
Jump to: navigation, search




Summary

  • Tweak all wording of built-in 'innertext:' help in file HelpText.cpp, including:
    • [GA] adding some help text for export
    • [GA] add text to 'innertext:recording' page about enabling monitoring.
    • [GA] In inner text for unsupported file format, remove reference to FLAC being unsupported. Draft submitted to devel-list to cover these three items
  • [RA] Update the Unix manual page  to distinguish between 1.3 and 1.2. In particular, remove reference to 1.3 importing multiple files from command line into the same Project, unless fixed before release (See Aim to for details).
  • Release note for loss of second imported track in Project after crash or loss of entire Project if second track is edited. Unless this is fixed before release.



Innertext:Recording

Needs text on monitoring. It currently reads:

To start recording, press the red Record button. Of course it's not quite that easy. There are three crucial settings you need to make:

  • (1) The "Recording Device", set in the Audio I/O tab of Preferences. By default Audacity will choose the current system device, usually your inbuilt sound device, so you may not need to set this. But if you're using an external USB or Firewire device such as a USB turntable, please check this device is selected as your recording device.
  • (2) The input source for your device, such as microphone, line-in [or stereo mix]. [If you're on Vista, choose your source in the "Recording Device" on the Audio I/O tab as above.] [Mac info]. Otherwise, choose your input in the dropdown selector on the right of the Mixer Toolbar. Note: many USB or Firewire devices won't have a choice of inputs, so you can ignore this step - see the documentation for your device.
  • (3) Input Volume: Before recording for real, make a test recording to set the input level of your recording so that it's neither too soft or too loud. To do this, adjust the input volume slider on the Mixer Toolbar (by the microphone symbol) so that when you record, the levels on the red VU recording meter in the Meter Toolbar are close to (but not touching) the right edge of the scale.

There is more help if you're stuck: our Recording FAQs, our Tutorial "Your First Recording" in the Manual, and our Wiki Recording Tips especially the Troubleshooting Recordings section.


Back to Welcome page.


Innertext:Export

No text at all. Currently reads:

Text about exporting still to be written...

Back to Welcome page.


Preferences

Directories tab

Auto save interval:

Currently

"Auto save every [ ] minutes"

Suggested replacement

None if [MM] changes autosave to strict interval saving as per aim-to. Wording needs changing if strict interval saving not implemented. Suggested would be "Auto Save interval" (fudge).


Save Changes? Dialogue with empty Project

Make Cancel to be the default button, not Yes (Yes as default is too dangerous).

This is NOT a wording change. wxMessageDialog supports YES, NO and CANCEL, but to make cancel the default we would need to rewrite wxMessageDialog. Should be moved off this page, to an aim to or to a not-aiming-to. (JC)

If we make 'Cancel' the default, change text of dialogue thus:

Currently

"To save the tracks that were previously open, click Cancel, Edit > Undo until all your tracks are open, then File > Save Project"

Suggested replacement

"To save the tracks that were previously open, click Cancel (highlighted), Edit > Undo until all your tracks are open, then File > Save Project"

I disagree. If cancel is highlighted, you don't need to tell the user that it is highlighted. (JC)


Done

  • Interface tab, Show/Hide: "Show Welcome Message at program start up" , was 'Splash Screen'.

  • Find Clipping: "Start and stop must be greater than 0", was 'positive and greater than zero'.

  • Dependencies dialogue: The former "Close" and "Skip" buttons now both read "Do not copy any audio".

  • Export Multiple progress dialogue: "Exporting the entire project as a WAV/AIFF file" or (for MP3) "exporting the entire file..." now changed to "Exporting entire project" with (filename) in the dialogue title and (format) above the progress bar.

  • Latency Shift Dialogue: In "I have brought it back to start at zero", "I have" has been replaced with "Audacity has".

  • Preferences: Interface tab: "Tracks &fit vertically zoomed" changed to "Automatically &fit tracks vertically zoomed"

  • "Audacious!" buttons -> "OK... Audacious!"

  • GUIPrefs.CPP:

- "&Select all audio, if none selected, on applying effect"

+ "&Select all audio in project, if none selected"

- "&Circular track keyboard navigation"

+ "\"Move track focus\" &cycles repeatedly through tracks"

- "&Quit Audacity upon closing last window"

+ "Any Close/Exit command completely &quits Audacity"


  • Import.CPP:

- " is an encrypted audio file, typically from an online music store. \nAudacity cannot open this type of file due to the encryption.\nYou need to convert it to a supported, unencrypted audio format."

+ " is an encrypted audio file. These typically are from an online music store. \nAudacity cannot open this type of file due to the encryption. \nTry recording the file into Audacity, or burn it to audio CD then \nextract the CD track to a supported audio format such as WAV or AIFF."

- " is an audio CD file. \nAudacity does not open this type of file.\nTry ripping it to a native audio format that Audacity can import."

+ " is an audio CD track. \nAudacity cannot open audio CDs directly. \nExtract (rip) the CD tracks to an audio format that \nAudacity can import, such as WAV or AIFF.");

Add "WAV or AIFF" references to Real, AAC and WMA:

- " is a RealPlayer media file. \nAudacity cannot open this..."

+ " is a RealPlayer media file. \nAudacity cannot open this proprietary format. \nYou need to convert it to a supported audio format, such as WAV or AIFF."

- " is an Advanced Audio Coding file. \nAudacity cannot open this..."

+ " is an Advanced Audio Coding file. \nAudacity cannot open this type of file. \nYou need to convert it to a supported audio format, such as WAV or AIFF."

- " is a Windows Media Audio file. \nAudacity cannot open this..."

+ " is a Windows Media Audio file. \nAudacity cannot open this type of file due to patent restrictions. \nYou need to convert it to a supported audio format, such as WAV or AIFF."



  • Default temporary directory: changed from "/tmp/audacity1.2-%USERNAME" to AUDACITY_VERSION, AUDACITY_RELEASE string