Wording

From Audacity Wiki
Revision as of 17:04, 18 October 2007 by James (talk | contribs) (formatting in code updated.)
Jump to: navigation, search




Summary

  • Tweak all wording of built-in 'innertext:' help in file HelpText.cpp, including:
    • [GA] adding some help text for export
    • [GA] add text to 'innertext:recording' page about enabling monitoring.
    • [GA] In inner text for unsupported file format, remove reference to FLAC being unsupported. Draft submitted to devel-list to cover these three items
  • [RA] Update the Unix manual page  to distinguish between 1.3 and 1.2. In particular, remove reference to 1.3 importing multiple files from command line into the same Project, unless fixed before release (See Aim to for details).
  • Release note for loss of second imported track in Project after crash or loss of entire Project if second track is edited. Unless this is fixed before release.

Innertext:Recording

Currently

Back to Welcome page.

To start recording, press the red Record button. Before doing so however, there are three crucial settings you must check:

(1) The Recording Device, set in the Audio I/O tab of Preferences. By default Audacity will use the current system device, which is usually your inbuilt sound device, so you may not need to set this. But if you're using an external USB or Firewire device such as a USB turntable, make sure this device is selected as your recording device.

(2) The input source for your device, such as microphone or line-in.

  • On Windows, you normally choose your input in the dropdown selector on the right of the Mixer Toolbar note: on Vista, you must do so at Recording Device on the Audio I/O Preferences tab.
  • On a Mac, you normally choose input sources outside Audacity, in Apple Audio-MIDI Setup. Note: many USB or Firewire devices don't have a choice of inputs, so you can ignore this step - see the documentation for your device.



(3) Input volume. Before recording for real, make a test recording to set the input level, so that it's neither too soft or too loud. To do this:

1. Turn on monitoring, by either double-clicking over the right-hand of the two VU Meters, or right-clicking over it and choosing "Start Monitoring". If you do not see the meters, click View > Toolbars and check "Meter Toolbar".

2. Press Record, and adjust the input volume slider on the Mixer Toolbar (by the microphone symbol), so that the red bars in the meter come close to (but do not touch) the right edge of the scale. If you can't hear the sound, go to the Audio I/O tab of Preferences and check "Software Playthrough".

There is more help if you're stuck: our Recording FAQs, our Tutorial Your First Recording in the Manual, and our Wiki Recording Tips, especially the Troubleshooting Recordings section.

Back to Welcome page.

Suggested replacement

OK as is? JC

Innertext:Export

Currently

Exporting and Saving. have different purposes. You " save" an Audacity project file when you want to return to your work in Audacity later. This means you don't then have to re-import or re-record audio, or redo editing you have done so far. When you want to listen to your work in other computer programs or burn it to CD, you "export" it as an audio file such as a WAV, AIFF or MP3. To save an Audacity project, use File > Save Project. This will save an .aup Project file, plus a _data folder containing the actual audio. Make sure you don't rename or move either of these, because Audacity needs to refer to both. Only use File > Save Project As. when you either need to save an empty Project, or if you want to save an existing Project to a new name. When you want to re-open a saved Project, simply click File > Open and open the .aup file.

When you want to export your work to an audio file, use File > Export and choose your desired format in the "Save as type" dropdown. Click the Options button for advanced choices, such as the bit rate to use for MP3 export. There are two other Export commands under the File menu. "Export Selection" exports only a selected area of audio. "Export Multiple" exports multiple files, for example where you have more than one track on screen and want to export each as a separate file.

Before you can export as MP3, you need to add the LAME MP3 encoder to your computer. For help with LAME, see Lame_Installation. There is also some help on how to burn to a CD.

Back to Welcome page.

Suggested replacement

OK as is? JC

Preferences

Directories tab

Auto save interval:

Currently

"Auto save every [ ] minutes"

Suggested replacement

None if [MM] changes autosave to strict interval saving as per aim-to. Wording needs changing if strict interval saving not implemented. Suggested would be "Auto Save interval" (fudge).


Save Changes? Dialogue with empty Project

Make Cancel to be the default button, not Yes (Yes as default is too dangerous).

This is NOT a wording change. wxMessageDialog supports YES, NO and CANCEL, but to make cancel the default we would need to rewrite wxMessageDialog. Should be moved off this page, to an aim to or to a not-aiming-to. (JC)

If we make 'Cancel' the default, change text of dialogue thus:

Currently

"To save the tracks that were previously open, click Cancel, Edit > Undo until all your tracks are open, then File > Save Project"

Suggested replacement

"To save the tracks that were previously open, click Cancel (highlighted), Edit > Undo until all your tracks are open, then File > Save Project"

I disagree. If cancel is highlighted, you don't need to tell the user that it is highlighted. (JC)


Done

  • Interface tab, Show/Hide: "Show Welcome Message at program start up" , was 'Splash Screen'.

  • Find Clipping: "Start and stop must be greater than 0", was 'positive and greater than zero'.

  • Dependencies dialogue: The former "Close" and "Skip" buttons now both read "Do not copy any audio".

  • Export Multiple progress dialogue: "Exporting the entire project as a WAV/AIFF file" or (for MP3) "exporting the entire file..." now changed to "Exporting entire project" with (filename) in the dialogue title and (format) above the progress bar.

  • Latency Shift Dialogue: In "I have brought it back to start at zero", "I have" has been replaced with "Audacity has".

  • Preferences: Interface tab: "Tracks &fit vertically zoomed" changed to "Automatically &fit tracks vertically zoomed"

  • "Audacious!" buttons -> "OK... Audacious!"

  • GUIPrefs.CPP:

- "&Select all audio, if none selected, on applying effect"

+ "&Select all audio in project, if none selected"

- "&Circular track keyboard navigation"

+ "\"Move track focus\" &cycles repeatedly through tracks"

- "&Quit Audacity upon closing last window"

+ "Any Close/Exit command completely &quits Audacity"


  • Import.CPP:

- " is an encrypted audio file, typically from an online music store. \nAudacity cannot open this type of file due to the encryption.\nYou need to convert it to a supported, unencrypted audio format."

+ " is an encrypted audio file. These typically are from an online music store. \nAudacity cannot open this type of file due to the encryption. \nTry recording the file into Audacity, or burn it to audio CD then \nextract the CD track to a supported audio format such as WAV or AIFF."

- " is an audio CD file. \nAudacity does not open this type of file.\nTry ripping it to a native audio format that Audacity can import."

+ " is an audio CD track. \nAudacity cannot open audio CDs directly. \nExtract (rip) the CD tracks to an audio format that \nAudacity can import, such as WAV or AIFF.");

Add "WAV or AIFF" references to Real, AAC and WMA:

- " is a RealPlayer media file. \nAudacity cannot open this..."

+ " is a RealPlayer media file. \nAudacity cannot open this proprietary format. \nYou need to convert it to a supported audio format, such as WAV or AIFF."

- " is an Advanced Audio Coding file. \nAudacity cannot open this..."

+ " is an Advanced Audio Coding file. \nAudacity cannot open this type of file. \nYou need to convert it to a supported audio format, such as WAV or AIFF."

- " is a Windows Media Audio file. \nAudacity cannot open this..."

+ " is a Windows Media Audio file. \nAudacity cannot open this type of file due to patent restrictions. \nYou need to convert it to a supported audio format, such as WAV or AIFF."



  • Default temporary directory: changed from "/tmp/audacity1.2-%USERNAME" to AUDACITY_VERSION, AUDACITY_RELEASE string