Release Notes 1.3.5

From Audacity Wiki
Jump to: navigation, search


These Release Notes describe:
  • Changes to 1.3.5 Beta as compared with 1.3.4
  • Issues with 1.3.5 Beta which were known at time of release

Audacity 1.3.5 for Windows, Mac OS X and Linux was current from 8 May 2008 to 23 October 2008.


Changes in 1.3.5

Recording / Playback:

  • Several bugs fixed so that latency correction should be better, and more devices work correctly.
  • Problems with invalid sample rates under Linux should be much rarer.
  • Newer version of Portaudio library.
  • New feature to record onto the end of an existing track (hold Shift while clicking Record).

Import / Export:

  • Updated versions of Libogg, Libvorbis, Libflac, Libsndfile and Twolame libraries.
  • Handling of unsupported file formats more informative.
  • Handling of file names with slashes on OS X improved.
  • New dialog allows replacement of illegal file name characters on all platforms.

Interface:

  • Improved scaling and layout for rulers and VU meters.
  • Envelope fixes/improvements including full control of undo/redo.
  • New keyboard shortcuts and improved menu navigation.
  • Preferences:
    • More intuitive tab arrangement.
    • New options for mute/solo and Metadata Editor behavior.
    • Language can now be changed without restart.
  • Expanded Build Information tab.

Effects:

  • New Vocal Remover plug-in, improvements for Generate effects.

Compilation:

  • Fixes when building Audacity with libraries disabled.
  • Improvements to make Mac and Solaris builds easier.

Security:

  • Full fix for issue CVE-2007-6061  on systems where temporary directories can be changed by other users (thanks to Michael Schwendt).

Miscellaneous:

  • Updated translations for many locales.
  • Several stability improvements.


Known Issues

All Platforms

  • If Audacity is built from CVS with wxWidgets 2.6.4 or later, the Escape key does not cancel most dialogs. This is due to a wxWidgets bug. In builds provided by the Audacity project, wx2.6.4 has been patched. This means that all dialogs can be cancelled by Escape when first opened, but in Preferences and Effect dialogs, keyboard users must now tab twice to reach the first field of the dialog. Additionally, for Preferences, GVerb, Hard Limiter, SC4 and user-added LADSPA/VST effects, once the user interacts with the dialog, it cannot then be cancelled by Escape without first tabbing to the OK or Cancel buttons.
  • Export Multiple fails with no export or warning if an empty label is encountered.
  • The preference "Hold recorded data in memory until recording is stopped" is misnamed. It caches most audio data for the duration of the session, including project data and imported files. Enabling it may cause a crash when making long recordings or opening large files or projects. Workround: When importing WAV or AIFF files, caching won't be done if the preference to read directly from the original file is enabled.
  • A few interface elements do not change language without restart. Workround: Use View > Toolbars... > Reset Toolbars.
  • Calculation of "disk space remains for recording (time)" is incorrect when recording in 24 bit quality. You may record for 50% longer than the indicated time.
  • Pressing Play (but not spacebar) in a second project when another is already playing stops playback of the first project.
  • Projects created by Audacity 1.1.x may open incorrectly.
  • Metadata such as ID3 tags is not fully imported and exported for all supported file formats. Patches to provide full orthogonal tag import and export would be welcomed.
    • All fields are imported and exported for MP3, as ID3 V2.3 tags. Some tools that don't support ID3 V2.3 tags properly will see no tags, or only some, including Windows Media Player which does not see "Year" tags.
    • All fields are exported to FLAC files but none are imported to Audacity on Linux (FLAC tags import properly on Windows). Not all players read all the fields properly, especially the Comments field.
    • All fields are exported to and imported from Ogg Vorbis files, but not all players read the Vorbis comments fully (VLC seems to only show them in the Advanced display)
    • Only a limited range of tags is exported to WAV files, and re-import is patchy. Player support is very patchy, as there is not a single standard for tagging WAV files.
  • No warning is given if File > Save or File > Save Project As... is carried out with no tracks open.
  • Not all menu items are correctly enabled when the preference: "Select all audio in project, if none selected" is checked.
  • Beep on completing long process may not be audible on many systems.
  • Audacity can import and display MIDI files, but they cannot be played or edited.


Windows only

Note: The Windows installer will not replace 1.2.x installations, but will install alongside them.

  • Welcome Message: On some systems/browsers, links are not brought to top, and some screen readers that otherwise work well with Audacity cannot read its text.
  • There have been reports of clicks during recording on some Windows XP systems using Audacity 1.3.4, where 1.2.6 had no problem. It is not clear if 1.3.5 will have this issue or if it will occur on other operating systems. Users can help us by e-mailing  with any reports of this problem.
  • Audacity is incompatible with some professional sound cards and may crash if one of these cards is the default when you open Audacity. As a workaround, make a different sound card your default when using Audacity, but please let us know if this affects you so that we can track down and solve the problem.


Mac OS X only

  • Some users find that after running Audacity other media players don't produce any sound or crash. Audacity tries to select the best quality settings your system is capable of, to give the best recordings possible. Some sound drivers also retain these settings as defaults for other applications, which can cause these symptoms. To get round this, enable the option "Do not modify audio device settings" on the Audio I/O tab of preferences, and make sure that your sound device is set up (in Apple Audio Midi Setup) to work in stereo, 16bits, with a sample rate of 44100Hz or 48000Hz. More help here.
  • Portable settings aren't picked up, and the default settings (in the default location) are always used. See this page for a workround.


Linux only

  • Audacity now supports interfacing with JACK , however this has not been tested, and is known to have a number of issues with both reliability and useability. Patches to improve both will be welcomed.
  • The first file imported into a project no longer changes the project rate to the file's rate, if that rate is absent from the project rate list.
  • (Debian-derived Linux only) System copy of LibSoundTouch is not detected correctly. When building Audacity from the source tarball, Audacity looks for a system copy of libSoundTouch 1.3.0 or later. If such is not available, the Change Tempo and Change Pitch effects cannot be used. On Debian and derived Linux systems this detection fails even when libSoundTouch is installed, because the pkg-config file used to detect libSoundTouch is named incorrectly. A bug report  was raised in April 2008. Workround: Either install the latest version of libSoundTouch (1.3.1), or symlink the installed file (/usr/lib/pkgconfig/libSoundTouch.pc) to the correct file name (/usr/lib/pkgconfig/soundtouch-1.0.pc). For example:
sudo ln -s /usr/lib/pkgconfig/libSoundTouch.pc   /usr/lib/pkgconfig/soundtouch-1.0.pc  
  • Note this requires 5th May 2008 CVS or later to work.