Release Notes 1.3.6

From Audacity Wiki
Jump to: navigation, search


These Release Notes describe:
  • Changes to 1.3.6 Beta as compared with 1.3.5
  • Issues with 1.3.6 Beta which were known at time of release

Audacity 1.3.6 for Windows, Mac OS X and Linux was current from 24 October 2008 until 26 January 2009.

Note: the Windows installer will not replace 1.2.x installations, but will install alongside them.


Changes in 1.3.6

  • Major new capabilities:
    • FFmpeg support (downloadable separately) permits import and export of a much wider range of file formats, including WMA, M4A and AC3, plus import of audio from video files
    • On-demand loading of uncompressed files eliminates the wait before files can be played or edited
    • Linked audio and label tracks allow labels to move with their corresponding audio when cutting, pasting or changing speed or tempo
  • Other features:
    • Hierarchical plug-in grouping for built-in plug-ins
    • Sound activated recording
    • Ability to save smaller, compressed project files
    • MIDI files can now be imported, cut-and-paste edited, then exported
  • Miscellaneous:
    • Transport menu for easy access to frequently used recording/playback commands and preferences
    • Default View Mode Preference to choose Waveform, Spectrum or Pitch view
  • Bugs fixed:
    • Crash in "Get Noise Profile" step of Noise Removal at project rates below 20480 Hz.
    • Underestimation of peak level in tracks with a small number of different peaks
    • Truncate Silence could result in repeated or lost audio if applied to the whole of a track
    • Other interface, generating, exporting and platform-specific fixes


Known Issues

All Platforms

  • Creating a Label Track (with or without a label), then pasting in error into any selected track before clipboard has any content causes a crash.
  • Muting/soloing specific stereo tracks when exporting may produce incorrect channel results in the exported file. A file exported from a single stereo track may have left channel only after use of solo/mute buttons.
  • Muting specific time-shifted mono tracks when exporting produces audio at wrong point on timeline in exported file if muted tracks are to left of unmuted.
  • Entering a negative three-digit value in "Change Speed", then previewing, raises an "Unhandled Exception" dialogue on which any of the "Abort, Retry, Ignore" choices cause a crash. Also possible freeze or crash on exit if a negative three-digit percent change is previewed in "Change Tempo" or "Change Pitch".
  • Nyquist plug-ins do not display moving bars in progress dialogue and over-estimate "Remaining Time"; if effect is cancelled, the unprocessed audio is deleted from the track, or Audacity crashes.
  • Change Speed and Change Tempo fail to modify the original selection length after applying the effect. Repeat fails to include the original selection region after applying the effect.
  • In projects containing many tracks, clips dragged at the bottom of the project may jump upwards into tracks towards the top when they pass the snap-to point with other clips.
  • Starting monitoring in Meter Toolbar after recording in another project window then closing it causes a crash
  • LADSPA Multiband EQ may not be visible in the Effect menu, and may crash in use.
  • On-demand:
    • does not work if using the optional FFmpeg importer (that is, if "FFmpeg-compatible files" set in the import window)
    • when importing a mixture of uncompressed and compressed files, on-demand loading does not start until normal import of the compressed files completes, if the names of the compressed files come earlier in the alphabet
  • Linked audio and label tracks:
    • Labels do not move with Effect > Repeat, Reverse, and Truncate Silence, or when time-shifting clips
    • When a Time Track is present, cut, copy and paste have no effect
  • Exports:
    • WAVEX (Microsoft) headers: GSM 6.10 files cannot be exported, and U-Law/A-Law files may not be playable
    • M4A: exports at rates below 44100 Hz have incorrect sample rates, and 38000 Hz exports may not play properly (FFmpeg bugs); M4A renamed to MOV will not play in Windows iTunes or QuickTime
    • MP3: Bit Rate Mode and Quality choices in MP3 Options dialogue are non-functional, almost always producing a 128 kbps CBR file. Reported length is often incorrect (the actual length is correct)
  • Export Multiple:
    • fails with no export or warning if an empty label is encountered.
    • "Other uncompressed files" choice always produces 16-bit PCM audio irrespective of header and encoding chosen in Options.
  • Some multi-channel recording devices that previously recorded more than two channels may no longer do so. Please e-mail reports to our feedback address.
  • When in Spectrum, Spectrum log or Pitch view, pasting in audio then zooming in causes the pasted content beyond the horizontal scroll to disappear.
  • Preferences window: OK button does not work when a tab is selected in the left-hand panel.
  • When more than one track is selected, and the region selected in the clips includes white space, "Split New" and "Noise Removal" cause the clip(s) to perform unwanted alignments instead of remaining at their original time position. The problem occurs whether or not the entire audio of the tracks is selected.
  • Split New: If selecting part of a clip from the left edge of the clip, the newly split clip wrongly aligns with the left edge of the residual clip in the original track.
  • "Audio Cache" on the Directories tab of Preferences caches most audio data for the duration of the session, including project data and imported files. Enabling it could cause a crash when making long recordings or opening large files or projects.
  • A few interface elements do not change language without restart.
  • Calculation of "disk space remains for recording (time)" incorrect when recording in 24 bit quality. You may record for 50% longer than the indicated time.
  • Pressing Play (but not spacebar) in a second project when another is already playing stops playback of the first project.
  • Projects created by Audacity 1.1.x may open incorrectly.
  • Metadata such as ID3 tags is not fully imported and exported for all supported file formats. MP3 tags *are* correctly imported and exported to the current ID3 specification, but some players don't fully support this specification, so may not see all the tags.
  • ID3 Genre tags of imported MP3s are misread (and will therefore also be exported incorrectly) if the genre list in Metadata Editor is opened and saved.
  • No warning given if File > Save or File > Save Project As... is carried out with no tracks open.
  • Not all menu items are correctly enabled when the preference: "Select all audio in project, if none selected" is checked.
  • Beep on completing long process may not be audible on many systems.
  • Audacity can import, display and cut/copy/paste MIDI files, then export them, but they cannot be played. Undoing an edit with a MIDI track open causes the MIDI data to be lost in Windows builds.

Windows only

  • LV2 support: LADSPA plug-ins not yet categorisable; the slv2 library needed for full LV2 support does not build.
  • There have been reports of clicks during recording on some Windows XP systems using Audacity 1.3.4 and later, where 1.2.6 had no problem. It is unclear if current releases will have this issue or if it will occur on other operating systems. Users can help us by e-mailing any reports of this problem to our feedback address.
  • Audacity is incompatible with some professional sound cards and may crash if one of these cards is the default when you open Audacity. As a workaround, make a different sound card your default when using Audacity, but please let us know if this affects you so we can track down and solve the problem.

Windows and Linux only

  • Welcome Message: On some systems/browsers, links are not brought to top, and some screen readers that otherwise work well with Audacity cannot read its text.

Mac OS X only

  • Very occasionally, users may find that recording causes "error opening sound device", or that after running Audacity, other media players don't produce any sound, or crash. To resolve this, set up your sound device in Apple Audio MIDI Setup to work in stereo, 16 bits, with a sample rate of 44100 Hz or 48000 Hz, and set the sample format and rate identically in Audacity. More help can be found in this Forum topic.
  • If using Audacity when the "Hear" audio plug-in is running (or has been since boot), there will be excessive memory usage which could cause a crash. This appears to be due to buggy memory allocation in "Hear".
  • Portable settings aren't picked up, and the default settings (in the default location) are always used. See this page for a workaround.

Mac OS X and Linux only

  • Labels do not accept certain legal characters. To work around it, reset the keyboard preferences to default (even if they are already default), or hold down ALT while typing.

Linux only

  • When importing larger WAV files with Import/Export Preferences set to "read directly", exporting to the same file by overwriting could result in a visually/audibly corrupted file.
  • Audacity does not build if EXPERIMENTAL_SCOREALIGN is defined
  • The first file imported into a project no longer changes the project rate to the file's rate, if that rate is absent from the project rate list.
  • (Debian-derived Linux only) System copy of LibSoundTouch is not detected correctly. When building Audacity from the source tarball, Audacity looks for a system copy of libSoundTouch 1.3.0 or later. If such is not available, the Change Tempo and Change Pitch effects cannot be used. On Debian-derived Linux systems this detection fails even when libSoundTouch is installed, because the pkg-config file used to detect libSoundTouch is named incorrectly. A bug report  was raised in April 2008.
    Workaround: Either install the latest version of libSoundTouch (1.3.1), or symlink the installed file (/usr/lib/pkgconfig/libSoundTouch.pc) to the correct file name (/usr/lib/pkgconfig/soundtouch-1.0.pc). For example:
sudo ln -s /usr/lib/pkgconfig/libSoundTouch.pc   /usr/lib/pkgconfig/soundtouch-1.0.pc