Release Notes 1.3.7

From Audacity Wiki
Jump to: navigation, search


Audacity 1.3.7 for Windows, Mac OS X and Linux was current from 28 January 2009 to 16 July 2009.

These Release Notes describe:

  • Changes to 1.3.7 Beta as compared with 1.3.6
  • Issues with 1.3.7 Beta which were known at time of release


Warning icon Notes for Windows:

Items struck out have been fixed in the latest development code, meaning that if you compile Audacity yourself from that code these issues should not occur.


Changes in 1.3.7

Cross-platform Bug Fixes

  • Muting/soloing caused incorrect channel results in exported stereo files
  • Noise Removal and all Nyquist effects pasted the original unmodified audio at the end of the modified region, if a label track existed and label/audio track linking on
  • Noise Removal inserted a tail of low level noise at the end of the modified region
  • Nyquist and Compressor plug-ins did not display moving bars in progress dialogue and over-estimated "Remaining Time"
  • Cancelling Nyquist effects deleted unprocessed audio
  • Change Speed and Change Tempo failed to modify the original selection length
  • Cut lines invisible
  • Fixed various bugs importing multi-stream files via FFmpeg
  • File > Export as WAV could be corrupted if overwriting an imported WAV read direct from the file
  • Export multiple "Other uncompressed files" choice always produced 16-bit PCM audio irrespective of chosen options
  • MP3 export usually produced a 128 kbps constant bit rate file irrespective of chosen options; reported length often incorrect
  • MP3 ID3 Genre tag misread on import if the genre list in Metadata Editor was opened and saved
  • Exported metadata tags in MP3, OGG and FLAC often not seen by player software - now substantially improved
  • WMA exports (via FFmpeg) corrupted if metadata tags included
  • Some multi-channel recording devices that previously recordedmore than two channels no longer did so
  • Generated audio did not fit in window
  • No warning was given when saving an empty project
  • Beep on completing longer process did not work on many systems
  • Fixed crashes importing lists of files (.LOF), in Meter Toolbar and Change Speed

Platform-specific Bug Fixes

  • Windows Vista:
    • Crash opening Preferences with no sound devices enabled and connected
  • Mac OS X and Linux:
    • Spurious clipping at start of playback
    • Labels did not accept certain legal characters
    • Shortcuts did not work after running effects or importing/exporting
    • Project Rate did not change to respect rate of first imported file if that rate was unsupported
  • Mac OS X only:
    • Crash resizing project window
    • Menu items became inactive or visibly corrupted or dialogues hidden
    • File > Open dialogue did not always work on OS X 10.4
    • Impossible to set independent Command and Control shortcuts that shared the same key
    • Freeze importing uncompressed files via On-Demand
    • Portable settings were not picked up, instead settings were taken from the default location
    • Fixed unavailability of FFmpeg installer

New Features

  • F11 Full Screen mode
  • High-quality "Sliding Time Scale/Pitch Shift" effect
  • Audio Contrast Analyzer for testing audio on the internet for WCAG2 accessibility compliance
  • Windows: sound devices can now be opened using the more efficient DirectSound API

Other changes

  • Latency correction should be improved for many users by employing a fixed rather than variable correction
  • Grouping of Effects into categories turned off until a way is added for users to do so themselves
  • Numerous minor interface improvements such as Metadata Editor navigation, new "hh:mm:ss + hundredths" selection format


Known Issues at Release

  • Analyze > Silence Finder and Analyze > Beat Finder crash on cancelling progress dialogue
  • Creating a Label Track (with or without a label), then pasting into any selected audio track before clipboard has content causes a crash; pasting into the Label Track does not crash
  • Muting specific time-shifted mono tracks when exporting produces audio at wrong point on timeline in exported file if muted tracks are to left of unmuted
  • In projects containing many tracks, clips dragged at the bottom of the project may jump upwards into tracks towards the top when they pass the snap-to point with other clips
  • Exports:
    • WAVEX (Microsoft) headers: GSM 6.10 files cannot be exported, and U-Law/A-Law files may not be playable
    • M4A: exports at rates below 44100 Hz have incorrect sample rates, and 38000 Hz exports may not play properly (FFmpeg bugs); M4A renamed to MOV will not play on Windows in iTunes or QuickTime
  • Export Multiple:
    • fails with no export or warning if an empty label is encountered
    • if user chooses to overwrite WAV files imported with preference set to "read directly", the exported files and the project are silenced. Workaround: Set the preference to "Make a copy..." or use the "FFmpeg-compatible files" import filter when exporting
  • Applying a chain including Equalization to files (File > Apply Chain... > Apply to Files) leads to corruption of the waveform
  • Cut Preview: when label track present and linking on, audio playback continues through the region instead of omitting it
  • Nyquist effects remove or corrupt cut and split lines in the modified region
  • If shortcut for "Add label at playback position" is an unmodified character, using it a second time while playing or recording a track enters that shortcut in a label placed at the start cursor
  • After using Plot Spectrum in one window then clearing to a new window, Plot Spectrum no longer opens until Audacity is exited and restarted
  • Preferences window:
    • overflows in some locales using smaller screen sizes or larger fonts, and on Macs at 1024x768 or smaller
    • "OK" button does not work when a tab is selected in the left-hand panel
  • LADSPA Multiband EQ may not be visible in the Effect menu, or may crash in use.
  • On-Demand:
    • does not work if using the optional FFmpeg importer (that is, if "FFmpeg-compatible files" set in the import dialogue)
    • when importing a mixture of uncompressed and compressed files, On-Demand loading does not start until normal import of the compressed files completes, if the names of the compressed files come earlier in the alphabet
  • Linked audio and label tracks:
    • Labels do not move with Effect > Repeat, Reverse, and Truncate Silence, or when time-shifting clips
    • When a Time Track is present, cut, copy and paste have no effect
  • When in Spectrum, Spectrum log or Pitch view, pasting in audio then zooming in causes the pasted content beyond the horizontal scroll to disappear
  • When more than one track is selected, and the region selected in the clips includes white space, "Split New" and "Noise Removal" cause the clip(s) to perform unwanted alignments instead of remaining at their original time position (occurs whether or not the entire audio of the tracks is selected)
  • Split New: If selecting part of a clip from the left edge of the clip, the newly split clip wrongly aligns with the left edge of the residual clip in the original track
  • Import > Audio produces no entries in File > Recent Files
  • "Audio Cache" on the Directories tab of Preferences caches most audio data for the duration of the session, including project data and imported files: enabling it could cause a crash when making long recordings or opening large files or projects
  • It is currently possible to attempt simultaneous imports or exports by using shortcuts (or File > New on Mac): Audacity is not yet capable of running these simultaneous operations safely, and attempting this may crash your project
  • Not all menu items are correctly enabled when the preference: "Select all audio in project, if none selected" is checked
  • A few interface elements do not change language without restart
  • Calculation of "disk space remains for recording (time)" incorrect when recording in 24-bit quality. You may record for 50% longer than the indicated time
  • Pressing Play (but not Space) in a second project when another is already playing stops playback of the first project
  • Projects created by Audacity 1.1.x or earlier are no longer supported: export each project track as WAV using the appropriate legacy version of Audacity, then import the WAV files into current Audacity
  • Audacity can import, display and cut/copy/paste MIDI files, then export them, but they cannot be played; undoing an edit with a MIDI track open causes the MIDI data to be lost in Windows builds
  • Windows (reported on):
    • There have been reports of clicks during recording on some Windows XP systems using Audacity 1.3.4 and later, where 1.2.6 had no problem: it is unclear if current releases will have this issue or if it will occur on other operating systems, so please help us by e-mailing any reports to us
  • Windows only:
    • Audacity is incompatible with some professional sound cards and may crash if one of these cards is the default when you open Audacity: as a workaround, make a different sound card your default when using Audacity, but please e-mail us if this affects you so we can track down and solve the problem
  • Windows and Linux only:
    • Welcome Message: On some systems/browsers, links are not brought to top when the browser is already running
  • Mac OS X only:
    • Very occasionally, users may find that recording causes "error opening sound device", or that after running Audacity, other media players don't produce any sound, or crash: to resolve this, set up your sound device in Apple Audio MIDI Setup to work in stereo, 16-bit, with a sample rate of 44100 Hz or 48000 Hz, and set the sample format and rate identically in Audacity (more help)
    • If using Audacity when the "Hear" audio plug-in is running (or has been since boot), there will be excessive memory usage which could cause a crash: appears to be due to buggy memory allocation in "Hear"
  • Linux only:
    • Audacity now supports interfacing with JACK but this has not been tested, and has a number of known reliability and usability issues: patches to improve both will be welcomed