Talk:Code Review Triage

From Audacity Wiki
Jump to: navigation, search

LabelTrack.cpp

James 16:36, 3 February 2010 (CST) Michael, thanks for adding code-review items to LabelTrack.cpp too.

  • Calling it constrain(inputval,min,max), I am fine with that.
  • "It doesn't look like we can delete it here, since 'other', which points to the same WaveClip is still used in the next if statement. " I still don't get what use is made of resampledClip. In the path where the resampling happens it looks like the results are not used. It needs a comment to justify it.

Briefly, we both agree about the need for more comments. We have slight stylistic differences in preferences, in that I prefer shorter functions and using the function names as 'self documenting code' whereas you would prefer to use a comment. I don't see us coming to blows over any of this, so I think we can progress. If you change the code it will be comments. If I change the code it will be shorter functions (in those two cases). It's a do-ocracy. Either way it will be better/clearer than what it is now.