Testing:Recording web-stream and exporting the result

From Audacity Wiki
Jump to: navigation, search
  • Peter 14Apr15: Ready for editorial review.
    • Gale 15Apr15: I made a few factual corrections. I think James is developing tests or log messages (?) for recording dropouts. When relevant, mention should be made of these tests here and in Testing:_LP/tape_transcription.

      I still feel that we have an opportunity we should not discard here and in Testing:_LP/tape_transcription to record timing of additional processes not listed in Testing. Would it not be possible to add these into the table in Testing, hyperlinked to the page in question?

      Also for one of the two recording test suites I think we should export metadata including some Unicode characters for all seven standard fields (these are expected to work for both WAV and MP3). Then import back the exported file and see if the metadata is present and correct.

    • Gale 02Apr15: Are these timing tests or just to see if the functions work? I suggested adding some of these actions to Testing: timing tests.
      • Peter 03Apr15: This is specifically not a timing test it is a functionality walkthrough based on a common Audacity use-case.
  • Peter 01Apr15:I deliberately decided not to embed this in a table as some of tests have text that would probably be too long for this, thoughts?
    • Gale 02Apr15: Perhaps the number of each section would be sufficient for a table.
      • Peter 03Apr15: I'll look into that, it could be a useful reporting mechanism.


This test is designed to cover the steps used to capture a live web-stream, perform some editing and export the result as an MP3/WAV. The test should take around two hours to complete.
Warning icon Work with Audacity set to a project rate of 44100 Hz and 32-bit sample format. These are the default quality settings, but use Edit Preferences to check and reset if necessary.

1. Set the recording device

On Windows (Vista or greater) in the Device Toolbar set the Host to be WASAPI and the Recording device to be " ... (loopback). On earlier versions of Windows you may be able to use the MME host with "Stereo Mix" (but this is not available on all PC's).

2. Software Playthrough

In the Transport menu ensure that Software Playthrough is turned "off".

3. Web-stream

Set the web-stream running.

4. Recording levels

Use monitoring to adjust and set your recording levels - aim for a peak of -6 dB or 0.5 on the waveform. If you are using WASAPI you will usually not be able to control the level of the achieved recording using the Audacity Recording slider. In that case adjust the recording level by adjusting the output of the application playing the audio.

5. Capture

Record one hour of the web-stream broadcast.

6. Raw master backup

Export a WAV for this recording at 32-bit float (not 16-bit).

7. Remove DC offset

Use Effect > Normalize to remove any DC offset. Use no amplitude adjustment at this stage.

8. Reduce web-carrier hiss noise

  • Use Effect > Noise Reduction's Get Noise Profile to obtain a noise sample.
  • Then use Effect > Noise Reduction on the entire project with the default settings:
    1. Noise reduction - 12 dB
    2. Sensitivity - 6
    3. Frequency (smoothing bands) 0

9. Remove ad breaks

In Edit > Preferences on the Interface pane ensure that "Retain labels if selection snaps to label edge" is checked "on". This will retain the label when deleting the audio, thus identifying where fades should be made in the next step.
  • Identify and mark with range labels any ad breaks (simulate this if none exist).
  • Delete each ad break: click in the label to select the ad audio and use Edit > Delete or the shortcut Ctrl + K.

10. Fade Outs/Ins

Fade out and in each side of the deleted audio as identified by the retained labels

  • Use Effect > Fade Out and Effect > Fade In either side of the removed audio. Normally fade ins are quite short (typically a fraction of a second) and fade outs longer (typically a few seconds).
  • Select the final 15 seconds of the recording and use Effect > Studio Fade Out

11. Amplitude adjustment

Normalize the amplitude of the recording using Effect > Normalize with Remove DC offset un-checked i.e. "off"

  • initial run with Normalize stereo channels independently checked "on" and with maximum amplitude set to -3dB
  • second run with Normalize stereo channels independently checked "off" and with maximum amplitude set to -2dB
  • now use Effect > Amplify, check the Amplification says 2.0 dB as expected then set New Peak Amplitude to -1dB.

12. Compression

Use Effect > Compressor, with default settings, on the entire project.

13. Export audio files

  • Use File > Export Audio to produce a WAV file at 44100 Hz 16-bit PCM stereo. Dithering should be set to the default Shaped in Preferences.
  • Use File > Export Audio again to produce an MP3 file at 192 constant bitrate and Joint Stereo (default bit rate is 128 kbps, so change the bit rate if necessary).



|< Testing