Unitary Project - issue tracking

From Audacity Wiki
Jump to: navigation, search
This page is to track the early issues with Unitary Project.
  • Later we may start using Bugzilla.

Contents

To-Do items

Ongoing items

White-Box analysis/testing

RESOLVED items

Warning icon Some of these items have not yet been tested on Linux.


UP-01 - initial launch Done.png

Done.png initial launch message

On initial launch I got a message asking if I wanted to associate .aup3 files with Audacity to click on for launch.

I never normally see such a message with any new versions. I don't get this on Mac Catalina. Leland says that this is expected behavior.


UP-02 - Save Project grayed-out Done.png

Done.png initial launch Save Project grayed-out on Win, Mac & Linux

This was a regression on 2.4.2 and earlier.


UP-03 - Drag&Drop Done.png

Windows

Done.png On Windows I can drag&drop an .aup3 file onto the Audacity app icon on my desktop, or onto an open Audacity project and it launches OK

  • Done.png Drag&Drop of an .aup3 file onto an audacity.exe in Windows Explorer or a desktop shortcut icon for it
  • Done.png Drag&Drop of an .aup3 file onto an open Audacity Window adds that project to the open project.
  • Done.png Drag&Drop of an .aup file onto an open Audacity Window succeeds (it adds to the open project)

Linux

Done.png On Linux: Steve wrote "I've tested drag & drop with simple AUP and AUP3 on Linux, and both work"

Mac

Done.png Peter 28Jul20: Testing with Latest alpha Audacity 3.0.0 09f7aaa 28Jul20

  • Done.png Drag&Drop of an .aup3 file onto an audacity.exe in Windows Explorer or a desktop shortcut icon for it - if and only if Audacity is not active in the apps bar
  • Done.png Drag&Drop of an .aup file onto an audacity.exe in Windows Explorer or a desktop shortcut icon for it - if and only if Audacity is not active in the apps bar but it's slow with the conversion
  • Done.png Drag&Drop of an audio or MIDI file onto an audacity.exe in Windows Explorer or a desktop shortcut icon for it - if and only if Audacity is not active in the apps bar
  • Done.png Drag&Drop of an .aup3 file onto an open Audacity Window adds that project to the open project.
  • Done.png Drag&Drop of an .aup file onto an open Audacity Window succeeds (it adds to the open project)
  • Done.png Drag&Drop of an audio or MIDI file onto an open Audacity Window succeeds (it adds to the open project)

Apart from the glitch that the Audacity in the apps bar must not be active for it to work drag and drop works fine, I shall log this as a bug in Bugzilla and then close this UP issue off.

Mac: Drag&Drop of a project file onto Audacity in Apps bar or Finder fails if Audacity is active in the Apps bar

Done.png On Mac I can't drag&drop onto either the Audacity icon in the apps bar or an open Audacity project

  • Done.png Drag&Drop of an .aup3 file onto an Audacity app in Finder or the Audacity icon in the apps bar
    Bill 17Jul2020: This behaviour is the same as 242 on Catalina. Drag&drop an AUP or audio file onto the Dock icon or Application icon when Audacity is not running (in 242) works. Do the same when Audacity is running and it does not work. Same now in 300. So it looks like we need to address the underlying issue on Catalina. This is Bug #2437.
    • Peter 26Jul20: I upgraded Bug #2437 to P2 as it attracts more visibility as a result of the UP
  • Done.png Drag&Drop of an .aup3 file onto an open Audacity Window fails
    Bill 17Jul2020: This now kind of works. Drag&drop an AUP3 into an empty Audacity window results in the project opening, but the project remains "untitled" (window title bar still reads "Audacity"). Closing the project window results in a "Save changes?" dialog. Surely this should just open the project, the same as File > Open.
    Bill 18Jul2020: Testing with e669b36, drag&drop an AUP3 file onto an empty project window results in the window taking on the name of the file. Closing the window gives a "save changes" dialog. I think this is OK - any drag&drop of any file into a project window (empty or not) should be considered an import.
  • Done.png Drag&Drop of an .aup file onto an open Audacity Window - behaviour unknown for now
    Bill 17Jul2020: Again, this kind of works. Drag&drop an AUP file into an empty project window and the AUP is imported, but the project window remains "Audacity". Seems to me the project name and window title should become the name of the AUP project that was imported. However you can drag&drop an AUP file into a non-empty project window and the AUP project will be imported into new tracks. So perhaps the project should remain untitled in these cases.
    Bill 18Jul2020: As above - this works. Any drag&drop of any file into a project window (empty or not) should be considered an import.
  • ToDo.png Bill 18Jul2020: In the above two cases, on closing and accepting to save changes, the file-save dialog box has no default name. I believe 242 would offer the window title as the default save file name. Shouldn't 300 do this?




UP-04 - more on Save Project Done.png

Done.png Once the initial Save As has been made - the for subsequent saves the Save Project is no longer grayed out and I can use it to save.


UP-05 - Amplify crashes Done.png

Done.png Amplify works on Mac

Done.png Amplify works on Linux

Done.png Amplify works on W10 - and still does with Audacity 3.0.0 e7fd679



UP-06 - Save location and name Done.png

I imported a file with drag&drop from my desktop, when I went to Save the Project I was offered

a) a very unsuitable location "Session Data" folder - should be last used save location or default location if first ever save

b) a rather oddly constructed name ...

Done.png Windows - Location offered is Documents\Audacity and the offered name is left blank

Done.png Mac - Location offered is Documents - offered name is left blank.

BUT on Mac it's always Documents after relaunching Audacity. While Audacity remains open the last-used location is remembered, bur is lost when Audacity is closed. See UP-08 below.

Done.png Linux - Location offered is Documents - offered name is left blank.


UP-07 - new project save name and location Done.png

Done.png Saving a new project - odd name (based on temp file) and location (Session Data) offered

Done.png Windows

Done.png Mac

Done.png Linux


UP-08 - last-used location not remembered Done.png

Done.png Windows: new settings in Directories preferences

Done.png Mac: new settings in Directories preferences

ToDo.png Linux - behavior unknown after changes for new settings in Directories preferences


UP-09 - error opening empty project Done.png

Mac

Done.png On Mac now works with Audacity 3.0.0 51b3b0f

Linux

Done.png Linux can open an empty project.

Windows

Done.png works properly on W10 with Audacity 3.0.0 e7fd679


UP-10 - timing tests ToDo.png

Done.png Some preliminary timing tests on W10 with Phase-1 build

UP-3.0.0 is a little slower than 2.4.2 right now 0 except for MP3 export which seems bang on the money.

Amplify takes more than double the time though.

Test file is a 3-hour stereo audio file

UP-3.0.0

  1. Import 3-hour WAV 1:31
  2. Amplify 3-hour audio 2:07
  3. Export 3-hour WAV 2:16
  4. Export as 3-hour MP3 4:36
  5. Import 3-hour MP3 2:07

2.4.2

  1. Import 3-hour WAV 0:50
  2. Amplify 3-hour audio 0.50
  3. Export 3-hour WAV 1:30
  4. Export as 3-hour MP3 4:35
  5. Import 3-hour MP3 1:12


Peter 15Jul20: I did some further timing tests on my Zurich PC today. Also an i7 256 SSD machine, but it seems faster than the HP Envy I have in Manchester for the 2.4.2 tests.

UP-3.0.0 2accd9e

  1. Import 3-hour WAV 0:35
  2. Amplify 3-hour audio 0:44
  3. Export 3-hour WAV 1:12
  4. Export as 3-hour MP3 3:37
  5. Import 3-hour MP3 1:03

2.4.2

  1. Import 3-hour WAV 0:15
  2. Amplify 3-hour audio 0.18
  3. Export 3-hour WAV 1:07
  4. Export as 3-hour MP3 3:40
  5. Import 3-hour MP3 0:45


UP-11 - MIDI Done.png

Done.png MIDI

On both W10 and macOS Catalina I can

  • import MIDI files
  • play MIDI tracks


UP-12 - recent files list Done.png

On Mac the Recent Files list is a bit iffy (Steve said the same about Linux)


Leland 07Jul20 Temporary filenames are showing up in the file history. Haven't looked into why as yet.

Leland 18Jul20 I believe the file history is behaving much better now. Paul fixed the temporary filename issue.

Done.png looks OK on W10

Done.png looks OK on Mac

ToDo.png still to be tested on Linux


UP-13 - Move and Rename a closed projectDone.png

Done.png Move and Rename

On W10 and mcOS Catalina I can:

  • rename a .aup3 file
  • move a .aup3 file to a different folder

and in both cases Audacity successfully opens it.

This is GREAT - as this is a tangle with old projects where losers could trip up and lose/damage their projects.


UP-13a - Move after Closing Done.png

It's unclear if this is a bug or desired behaviour. It will go away if we clear the clipboard on closing a project. Paul is very very keen on keeping the clipboard around after closing the Audacity project.

Paul 07Jul20 I'm no longer very keen: I wanted to keep old behavior if it was not difficult to do safely, but now I have been persuaded that there are enough hidden difficulties.

And Paul has now fixed this. RM is fine with the tiny 'regression', that you can close a project and lose a clipboard that previously would have hung around until you close Audacity (and that caused all sorts of problems).


UP-14 - Recovery Done.png

Leland 18Jul20: This should all be retested since many changes have been made that would have affected Recovery.

Windows

Done.png Recovery needs retesting

Mac

Done.png Recovery needs retesting

Linux

ToDo.png Recovery needs retesting


UP-14a - Recovery dialog should show all recoverable projects Done.png

Now that we know how to ungracefully kill an Audacity process on PCs this appears to be sorted

  • Done.png Windows
  • Done.png Mac
  • ToDo.png Linux behavior unknown


UP-15 - cannot update a project Done.png

Windows

Done.png works properly with Audacity 3.0.0 e7fd679

Mac

Done.png works properly with Audacity 3.0.0 e08fb5e

Linux

Done.png works properly with Audacity 3.0.0 e08fb5e



UP-16 - Nyquist EGATs crash Done.png

Done.png With Phase-2 Audacity 3.0.0 e7fd679 these all now work. I'm guessing that the fix for Amplify crashing also cured all these.

Phase-1 On Windows and Mac most shipped Nyquist effects, generators, analyzers and tools crash Audacity.

The only three that work are

  • Tremolo
  • Vocoder
  • Rhythm track

Done.png All above the line effects, generators and analyzers work


Done.png Linux - All effects and generators tried so far (including the above three) work correctly.


UP-17 - Projects can be larger on UP-3.0.0 ToDo.png

Initially Projects in UP-3.0.0 could be much larger than the equivalent project in 2.4.2

Re-test later

ToDo.png we will need to retest later as the UP development project progresses

Projects are slightly larger as they develop on 3.0.0 than 2.4.2 - but on exiting Audacity 2.4.2 releases space whereas 3.0.0 does not. "Vacuuming" is what is needed, but when and with what trigger(s)

Leland 18Jul20: This should now be corrected as vacuuming at project close has been added.

Windows

Done.png testing on Audacity 3.0.0 6c2cd20 - the bloat-space is released on exit from Audacity (it is slow though seeUP-18)

Testing with a 5 hour mono chirp

  • Audacity 3.0.0 0fbabb0 the .aup3 file occupies 3.134GB
  • Audacity 2.4.2 the ,aup and data folder occupy 2.99GB

This for me is within acceptable limits

ToDo.png retest

Mac

Done.png testing on Audacity 3.0.0 6c2cd20 - the bloat-space is released on exit from Audacity (it is much quicker than Windows)

Done.png Bill 18Jul2020: Testing with e669b36: 2.4.2 AUP +_data is 100 KB + 675.2 MB; 3.0.0 AUP is 680.7 MB. Bloat is removed on close.

Linux

Done.png with Audacity 3.0.0 6c2cd20 - the bloat-space is released on exit from Audacity

ToDo.png retest


UP-18 - Closing Audacity is slower with UP-3.0.0 Done.png

Leland 18Jul20: This should be much better now. It’s still possible that it will be somewhat slower that 2.4.2 since vacuuming may occur. But, when it doesn’t closing should be just about the same as 2.4.2.

Windows

Done.png Testing on W10 with Audacity 3.0.0 0fbabb0 - seems fast enough to me and with a good progress dialog

Done.png retest

Mac

Done.png But Exit or Quit on Mac is much faster than on W10 taking a mere 3-4 seconds cf. 20-plus seconds on W10 with the same project steps.

  • Is this acceptably fast for a one-hour mono project ?

Done.png retest Bill 18Jul2020: Testing with e669b36. 680 MB project, duplicate stereo track, amplify duplicated track (doubles project size), delete track, close and save. Vacuuming takes less than 2 seconds. Acceptable.

Linux

ToDo.png Better than before. It's still slower than 2.4.2, which was virtually instant, but nowhere near as slow as it was initially.

I've not tested this extensively, but closing a saved project seems to take a lot longer than closing an unsaved project.

Done.png retest


UP-19 - Easier opening and deleting Done.png

Done.png It's much easier to find projects for opening and for deleting them

I'm finding that just after a couple of days testing the UP is much easier to manage:

  • Open: only one thing to look for, you don't get confused trying to "Open" the data folder
  • Delete: also only one thing to look for - and on W10 at least the folders and files are always separated so tour aup could be a long way away from its data folder (which could lead to fumble-fingers trouble)


UP-20 - Aliased Projects Done.png

It is possible that some users may still have projects that are relying on aliased files - and note that ODL has been removed from 3.0.0

  • Done.png P1 Bug #2188 ENH: No warning is given on project opening that the project is not self-contained and relies on aliased file(s
  • P2 Bug #2187 - Silent crash with no error message when using a missing aliased audio file
    • Done.png Windows: works fine on W10 with Audacity 3.0.0 2accd9e
    • Done.png Mac: Bill 22Jul2020: With commit 7bb2417. With missing alias file, a warning is given. With alias file found it is silently copied in - is this what we want to do? In the manual perhaps note that this happens. 2.3.2 was the last version that supported alias files.
      • Peter 22Jul20:I think it's fine that we silently copy in and make a consolidated project in this opaque fashion.
    • ToDo.png Linux: still to be tested


UP-21 - Backup command Done.png

Done.png new Backup Project command

In 3.0.0 Save Compressed Copy of Project and Save Compressed Copy of Project

QA discussed the Backup Project issue and rapidly reached agreement.

1) QA likes the short form of the command File > Save Project > Backup Project

2) And QA agrees that there should be no overwrite of backup projects (or any other projects with the Backup command).

Accordingly the current error message used for the deprecated Save Lossless... and Save Compressed... can be used as-is:


UP-22 Import .aup projects Done.png

Done.png We need an import utility for .aup projects from Audacity 2.4.2 and earlier.
Bill 22Jul2020: There was an AUP import bug that was fixed in commit 7bb2417 so this should probably be retested
This is what I found.

  1. In Audacity 2.4.2, import or create a stereo track with exactly 5 minutes of audio
  2. Save the project
  3. Quit 2.4.2
  4. Start Audacity 3 commit 0c14e61
  5. Open the project from step 2
  6. Zoom into the end and play the last 10 seconds of the track
  7. Observe - there is audio missing from about 4m 57.215s to the end
  8. The waveform is there but if you zoom in far enough the waveform disappears - not even a flatline
  9. If you now zoom out and select the entire track and do Repeat with 3, you will see gaps between the repeats.
  • Done.png Windows - works properly - can be opened or imported
    • Peter 22Jul20: reteste with Audacity 3.0.0 7bb2417 - all fine, Bill's steps now work with no missing audio
  • Done.png Mac - Bill tested the actual importing when he worked on UP-03. The only thing he did do was the “File -> Import…” bit.
    Bill 18Jul2020: Did File > Import > Audio, selected an AUP file, imported fine.
    Bill 22Jul2020: tested with commit 7bb2417 - working fine.
  • Done.png Linux - Steve reported by emails that this works properly

See UP-20 Aliased Projects

ToDo.png Importing audio into an empty unsaved project crashes Audacity.

  • AUP3 and AUP files can be imported OK into an empty unsaved project
  • Audio files can be imported if other audio is first created or if the project is first saved
  • Done.png Windows - tested on Audacity 2.3.3 12f0c6e
  • Done.png Mac - tested on Audacity 2.3.3 12f0c6e
  • ToDo.png Linux - as yet untested


UP-23 - Macro commands Done.png

  • Done.png the new backup Macro command "Save Copy" offers a file with extension .aup and not .aup3
  • Done.png the existing Macro command "Save Project2" offers a file with extension .aup and not .aup3

The new backup Macro command "Save Copy" appears to effectively be a duplicate of "Save Project2"

  • Leland 07Jul20: it’s really not a duplicate (I had the feeling at first too). The difference is that once “Save Project2” writes out the new file, that file becomes the active one. With “Save Backup” the original file remains the active one.


UP-24 - Timer Record Done.png

Done.png Timer Record works fine.

Tested with Automatic save and Automatic Export


UP-25 - Disk-space exhaustion ToDo.png

Check that disk-space exhaustion error traps still work properly - It Didn't

Paul indicates that this may have changed with SQLite 3.0.0 - so needs re-checking.

  • Done.png Windows
  • Done.png Mac - all OK except Use Case 5 - temp directory to be on the USB stick. This is logged as P1 regression Bug #2530
  • ToDo.png Linux - Needs testing on Linux
    • ToDo.png Linux behavior unknown


UP-26 Stress Tests ToDo.png

  • Done.png Very long projects
    • Peter 14Jul20: Overnight I tested a Timed Recording of 5 hours and dis the production work to whittle it down to the required 2 hours and exported - all on Audacity 3.0.0 0fbabb0. Audio was fine - I had a label track issue that I can't now reproduce.
  • Done.png Simultaneous playback and recording
    • James requested: Can you do some testing of play-through record please Peter? The point there is that we are both reading and writing the database, so there might possibly (low probability) be new issues around lock files. It's unlikely, but let's find out. So for worst results, play back a mix of 4 stereo channels, and record stereo and at the highest sampling rate your card offers at the same time. If we're unlucky this might get SQLite in a twist. It might try to do things in big batches and lock us out for too long.
    • This worked fine on W10 with my Edirol UA-1EX
  • Done.png Projects with many, many, tracks
    • Eventually I get "Out of memory" - but that needs a huge number of tracks

UP-27 Deleting, Moving renaming active project files Done.png

Leland 18Jul20: As I mentioned in some emails, there’s no real way to prevent the deleting or movement of “.aup3” or “.aup3-wal” files on Linux or OSX. Only thing you can do is give a stern warning in the manual.

Done.png make sure there is a stern warning in the Manual for Mac and Linux Peter 20Jul20: Done seethis page on managing Audacity projects

Windows

Done.png Audacity prevents Deleting, Moving or renaming active project files: .aup -wal and -shm while a project remains open

Mac

You can delete the AUP3 and WAL

Linux

You can delete the AUP3 and WAL on Linux.




UP-28 Use of OS to create a copy project Done.png

Leland 18Jul20: This should be the same on all platforms. You can copy the AUP3 file around all you like...just don't do it while Audacity has it open.

Done.png Windows: use Windows Explorer to copy a project. Open it with Audacity

Done.png Mac: use Finder to copy a project. Open it with Audacity - works OK

ToDo.png Linux: behavior unknown

Done.png issue a stern warning in the Manual for: "just don't do it while Audacity has it open"


UP-29 Save Project does not propagate project name to Audacity window Done.png

Save Project does not propagate project name to Audacity window This is a regression on 2.4.2

Done.png Windows: Testing on W10 with Audacity 3.0.0 2accd9e - this now works properly

Done.png Mac: Testing on macOS with earlier Audacity 3.0.0 b12fafb

ToDo.png Linux: behavior unknown


UP-30 On Mac second use of Save Project As has bad name/location Done.png

Leland 18Jul20: This seems to be working fine now.

Done.png On Mac second use of Save Project as has bad name/location

Bill 18Jul2020: With build e669b36 the second Save As offers the project name as the default file name, and defaults to the folder where the project was last saved.

On Mac when I first use Save Project As I get a blank filename offered and Documents as the location (which is good)

When I next use Save Project As a) The location offered is Session Data (this is bad) b) The project name field has: New Project 2020-07-10 11-53-11N-2.aupunsaved.aup3 - which looks like a temp filename c) Pressing Save button saves it with that rubbishy file name

Windows is not similarly affected

ToDo.png Linux behavior is unknown.

Done.png Windows - works fine


UP-31 X-platform compatibility of AUP3 project files ToDo.png

Paul raised this issue by email.

James replied:

  • We do not expect it to be cross platform at the moment. Our integers are the wrong way round.
  • As RM I expect us to be revisiting the binary format and using a fixed endianness.
  • It will not hurt performance.
  • I also expect to use a more compact autosave format than now, but not zipped, better for recording, and to be doing that during 3.0.0.

Windows

  • Done.png Windows => Mac
  • Done.png Windows => Linux

Mac

  • Done.png Mac => Windows
  • Done.png Mac => Linux

Linux

  • Done.png Linux => Windows
  • Done.png Linux => Mac


UP-32 Backup Projects show error on opening Done.png

Steve wrote by email: I'm frequently seeing the error message when opening a backup:

"This project was not saved properly the last time Audacity ran.
It has been recovered to the last snapshot."

Steps to reproduce:

  1. Launch Audacity
  2. Generate "Chirp"
  3. "Save Project" - name it "a"
  4. "Amplify"
  5. "Backup Project" - name it "b"
  6. "Undo" (undo Amplify)
  7. "Undo" (Undo Chirp)
  8. Generate "Tone"
  9. "Save Project" (updates "a")
  10. Exit Audacity
  11. Relaunch Audacity
  12. "Open" -> select project "b".
  13. Observe: "This project was not saved properly the last time Audacity ran. It has been recovered to the last snapshot."

Steve 13Jul20: fixed in commit 6f233cbff

  • Peter 13Jul20: Confirmed on W10 with Audacity 3.0.0 6f233cb
  • Bill 22Jul2020: Confirmed fixed on Mac with commit 7bb2417


UP-33 History window shows misleading "space used" ToDo.png

The "Total space used" in the History window may indicate much less than the size on disk.

Steps to reproduce:

  1. Generate 1 hour Rhythm Track
  2. Save Project
  3. Undo
  4. Generate 1 second "pluck"
  5. Observe: The project size is over 600 MB with 1 second of audio and hardly any Undo history (only the "Pluck").
  6. Observe: "View menu > History" shows: "Total space used: 172.3 KB"

Proposal:

  1. For the History window to indicate both "total space used" and "size on disk" for the project.
  2. For the History window to provide an option to "compact project" (vacuum the project) to reclaim disk space.


Peter 16Jul20: Steve wrote by email: This is looking better, but I'm not sure that compacting is working correctly.

I've been playing with a project, adding long tracks and deleting them to build up a large database, then deleting all tracks and generating a 1 second "ping".

  • On saving and closing, the AUP3 file was 1.3GB.
  • On "compacting" with "DB Browser for SQLite", the file size went down to 524.3 kB (524,288 bytes).

The checkbox "Compact at close" is selected.

Leland 28Jul20: I’ve pondered this some and it’s going to be difficult to get an exact size comparison. We can maybe get closer, but unless we can correlate the SQLite b-tree path to a specific sample block, then close is about as good as we’re going to get. Let me play a bit.


UP-34 Dirty Project-1 Corrupted unopenable project Done.png

Corrupted unopenable project

  1. Import some audio.
  2. Save and name the project - note file size
  3. Close the track.
  4. Generate something
  5. Close the project
  6. “Save Changes?” - No
  7. Observe: project is compacted - note file size has changed
  8. attempt to open the project
  9. Observe: "Message: failed to retrieve samples”

Reported by Bill on Mac, confirmed by Peter on Windows

Bill 17Jul2020: With build _1f87d4f, at step 7 the file size does not change significantly; at step 9 the project opens properly showing the audio imported in step 1.

UP-35 Bloat retention Done.png

Done.png Unremovable database bloat.



UP-36 Failure to Save new empty project Done.png

Done.png Windows: this now works fine on Windows with Audacity 3.0.0 d2b4a0e

Done.png Mac: Bill 17Jul2020: With build 1f87d4f, no error after step 2; at step 7 get warning "Your project is now empty..."; click Yes, project is saved.

ToDo.png Linux: current behavior unknown - needs testing



UP-37 Crash with an empty project Done.png

Done.png Testing on W10 with Audacity 3.0.0 5652b9b - this works fine
Done.pngBill 22Jul2020: testing on Mac with commit 0c14e61 this works fine


UP-38 Default File Save Location Done.png

Bill 20Jul2020: If the audacity.cfg contains the preference "[SaveAs]<newline>Path=/Users/<etc>" then 3.0.0 will use that as the default save-as location.

Version 2.4.2 ignores this setting and instead uses "DefaultOpenPath=/Users/<etc>" for the default save-as location.

Furthermore, version 3.0.0 does not write to this setting when using a different save-as location. The upshot is that a user of 3.0.0 will always get the location from the "[SaveAs]" setting (if they have one - apparently starting with a virgin CFG this setting will never be created).

IMO 3.0.0 should behave the same as 2.4.2 unless we decide otherwise. In any case the current behaviour of 3.0.0 is unacceptable.

There may be a bugzilla enhancement request for user preferences for default Open / Save / Export / Export Multiple paths.

Done.png Mac

Done.png Windows

Done.png Linux


UP-39 First use of Save Project crashes Audacity and infinite recovery Done.png

Testing on W10 with Audacity 3.0.0 7e9a3f4

Using Save Project, first use of Save Project crashes Audacity.

  1. Launch Audacity 3.0.0 7e9a3f4
  2. Generate > Chirp
  3. Save Project
  4. Observe: Audacity crashes - leaves WAL and SHM files hanging around
  5. relaunch
  6. Observe: recovery dialog
  7. accept recovery
  8. Observe message "This project was not saved properly the last time Audacity ran. It has been recovered to the last snapshot."
  9. Observe: 30 minute chirp looks intact
  10. Save Project
  11. Observe: no crash this time
  12. Exit (project should be "clean")
  13. Observe: WAL and SHL files STILL hanging around
  14. relaunch
  15. Observe: recovery dialog again

And you can go round and round this recovery loop.

Plus, once again, when I try to use Save As or Backup I get offered "Session Data" as the location !

Bill 22Jul2020: with commit 0c14e61 this is fixed on Mac

Peter 22Jul20: Fixed with Audacity 3.0.0 7bb2417

UP-40 Compact Project Done.png

Leland has introduced a new command to compact the project - we subsequently removed this cimmand

Done.png "File > Compact project" removed

UP-41 Opening a Saved project can get a "Project Recovered" message Done.png

Testing on W10 with Audacity 3.0.0 757bc0b - also happens on macOS 10.15.6

At its simplest:

  1. Launch Audacity
  2. Save Project (as projname say)
  3. Exit
  4. relaunch
  5. Observe: Project Recovered dialog

I get the same if I generate a chirp as step 1.1 Which is what I need for my test Macro - and this bug kiboshes that Macro nicely ...

The workaround is to

  1. Accept the offered recovery
  2. Save the "recovered" project overwriting projname.aup3
  3. Exit
  4. Relaunch
  5. Observe: no recovery dialog
  6. Open Project projname
  7. Observe: Project projname opens

Peter 28Jul20: Tests OK with Audacity 3.0.0 09f7aaa


UP-42 Compact Project needs a "?" help button Done.png

Done.png "File > Compact project" removed


UP-43 Compaction: pauses with no progress dialog Done.png

This is logged as P2 Bug #2531 (marginal P1)

  • Done.png OK now on Windows
  • Done.png OK now on Mac
  • ToDo.png Linux behavior unknown


UP-44 Molestation of project files when applying Macros Done.png

Cliff reported that if you apply a macro to "Files" and you had a "saved project" open at the time, you would get the "not saved properly" dialog when you next open that "saved project".

I can reproduce this on Windows but not on Mac - steps are

  1. Launch Audacity
  2. Generate chirp
  3. Save Project as chirp.aup3
  4. open new project
  5. Run a Macro on files from the new project
  6. Close new project without saving
  7. Close chirp.aup3 project and exit Audacity
  8. Launch Audacity
  9. Observe: Recovery dialog for the new unsaved project (from steps 4-6)
  10. Accept Recovery
  11. Observe: the "not saved properly" message


In fact you don't need the open/saved project to get this - simpler steps to reproduce

  1. Launch Audacity
  2. Run a Macro on files
  3. Close new project without saving
  4. Launch Audacity
  5. Observe: Recovery dialog for the new unsaved project (from steps 4-6)
  6. Accept Recovery
  7. Observe: the "not saved properly" message

Windows

Done.png Commit 000bf179 fixes this on Windows 10

Mac

Done.png Commit 000bf179 fixes this on Mac (macOS 10.15.6)

Linux

Done.png Commit 000bf179 fixes this on Linux.


UP-45

UP-46

UP-47

UP-48

UP-49

UP-50