Wording

From Audacity Wiki
Jump to: navigation, search
The text on this page should only be modified by subscribers to Audacity-devel mailing list.

To understand what this page is for and how it is used, please join that list or read the list archives on Sourceforge.
The discussion page can be used by anyone to make suggestions and comments about this page.


Warning icon James 26June16: This page should contain agreed wording changes that should be applied in time for 2.1.3 (including translation). Some of the changes on this page are actually not agreed changes, and
(a) haven't been applied to the source code and
(b) are now marked to show that they are not agreed.
  • Gale 02Nov16: If this page is supposed to contain alternatives for discussion then it can't only contain "agreed" changes. Should we use the Talk page to develop ideas?
  • James 03Nov16: Yes. Talk page for developing ideas/discussion. Page itself for joint agreed position. e.g. this page could just say
    • Select all on none - Under discussion.
    • Program -> App - Almost agreed.


Warning icon Peter 19Apr16: future entries on this page should show the date they were added - then we can see how long they remain here uncompleted.
  • The list is for finalizing text and processing typos that appear in the Audacity interface with the code as it is now.
  • This is a companion to Bugzilla for source code bugs.
What does not belong here:
  • Other source code changes that may require changes in text in Audacity as a consequence
  • Changes to the GUI such as moving buttons or controls from one place to another
  • Changes to the bundled Manual - these are tracked in ednotes on the pages concerned.
Warning icon In the period between translation freeze and release it may also be useful to store agreed "cosmetic" wording changes here that are not worth breaking translations for, but which should be dealt with after release. Such changes should be stored inside their own heading at the top of the page.

Contents


Typos

Effects

Toolbars

  • Selection Toolbar: "Project Rate (Hz):" has a trailing colon which should be removed. This is a residual hangover from 2.2.0 and earlier, when James updated the Selection Toolbar for 2.2.0 the traing colons from other descriptors in this toolbar were removed. So we should remove this one for consistency.

Toolbar Widget Names

These names are not visible, but are read by screen readers. The consensus is that they should not have a colon at the end:

  • Project Rate (Hz): in SelectionBar::Populate()
  • Center Frequency: in SpectralSelectionBar::Populate()
  • Bandwidth: in SpectralSelectionBar::Populate()
  • Low Frequency: in SpectralSelectionBar::Populate()
  • High Frequency: in SpectralSelectionBar::Populate()

Tooltips

Preferences

Status Bar

References to audacity.sourceforge.net

The following files in our codebase contain one or more references to audacity.sourceforge.net:

  • \lib-src\FileDialog\configure
  • \lib-src\libnyquist\README.txt
  • \lib-src\libsndfile\ChangeLog
  • \lib-src\portmixer\configure
  • \src\export\ExportFFmpegDialogs.cpp
  • \src\xml\audacityproject.dtd
  • \src\Project.cpp
  • \tests\ProjectCheckTests\missing_aliased_and_auf_files.aup
  • \tests\ProjectCheckTests\missing_blockfile.aup
  • \tests\ProjectCheckTests\orphaned_blockfiles.aup

Modernization: program to application

Warning icon The 'Program' to 'Application' change is almost agreed
(a) because there may be more places not yet identified where it needs to change.
(b) because there are still alternative suggested wordings being suggested.

RM for 2.1.3 (James) is OK with this change being made, but believes that 'Program' includes 'Application' so the current wording does not have to change.
Gale 01Nov16: Replying to James's "alert", I did search the code and I think all instances of "program" are listed here. I don't know when the freeze is but I'm prepared to commit my take on this, leaving out the few that are unclear. We can always change those others later. I think this change is moderately important in making Audacity look less dated.
  • JC: Invitation to go ahead, so that we can clear this item off this page and demote the wording bugzilla item from P2.
  • Gale 02Nov16: There is no implied Bugzilla rating for items on this page as far as I know, unless P2 is assumed unless stated otherwise. An embarrassing typo could be P1.
  • James 03Nov16: Ideally the Bugzilla bug's rating is the 'highest' of the rating for any of the agreed wording changes on this page. A P1 embarrassing typo should either be fixed immediately, or Bug 1427 should be raised to P1. Clearly a P1 typo should block release! If we've only got unagreed changes in this queue, Bug 1427 should drop to P4 (or be marked DEVEL-FIXMADE). That tells RM that QA sees no Wording changes serious enough to block on. Generally RM would want this page 'empty' and Bug 1427 DEVEL_FIXMADE or P4 before translation freeze.

Following recent QA discussion on email it was decided to modernize Audacity by changing Program to application as more contemporary usage throughout the documentation. Most of the changes in the Manual have been done, but there remain places in the code that need to be changed before we can update their associated pages in the Manual.

  • Gale 12May16: Where is that discussion on http://audacity.238276.n2.nabble.com/audacity-quality-f7561562.html ? I only see an offlist discussion. There are more places in the interface than you mention:
    • src/AboutDialog.cpp:215 "Audacity is a free program..."
    • src/AboutDialog.cpp:524 "Program build date"
    • src/effects/nyquist/Nyquist.cpp:2056 "Current program has been modified"
    • src/effects/vamp/VampEffect.cpp:622 "Program"
    • src/export/Export.cpp:636 "Normally these files end in \".%s\", and some programs will not open files..."
    • src/prefs/ThemePrefs.cpp:101 "when the program starts up"
      • Peter 13May16: Not on nabble because a limited Quality Assurance discussion (DL: Gale, Steve, Peter, Bill - as active Manual editors. And yes I realized that there might well be other places in the code that I had not been able to discover, thanks for that digging.

Export Audio dialog

The "Save as type" dropdown

Current text:

"(external program)"

Suggested replacement:

"(external application)"

  • Steve 18May16: An "application" usually refers to a computer program with an interface. At the least, an "application" usually refers to a computer program that has interactive input and/or output (usually a "GUI" but may be an "application command line interface"). In this case we are referring to a "command line program" that takes parameters only from the initial command. To simplify this point "C-Dex", "RazorLame", "WinLame" and similar are "applications", whereas "LAME" is a "program".
  • Gale 18May16: When saving/loading VST presets these are called "programs" in our interface, but I think "program" is correct there. I am less sure "(external application)" is wrong. After all it can be used in a terminal window, it's Audacity's choice not to do so. And it is an EXE file on Windows. If it was my choice I would allow "(external application)". That apart, is there any consensus for these changes? Steve had not spoken before, so I've done nothing about it. I'm about +0.8 - users on older Windows may be confused - but that problem will decline.
  • Peter 18May16: My understanding was that on the limited DL of Gale, Steve and myself we had consensus on this, Bill was included too but made mo comment. The basic problem started when I discovered a few weeks ago that the Manual was inconsistent a few weeks ago using both forms in different places. I wrongly assumed it was confined to the Manual (hence the limited DL) and started work on the changes to bring it into line with "application". Part way through I realized that it affected the Audacity application itself with "program" used in some dialogs. Like Gale I would opt for "(external application)" in this dialog. I was, and am still, loath to widen this out to a Team vote or a devel list discussion over such a relatively trivial issue.
    • Gale 18may16: I am unsure in what context Nyquist.cpp:2056 "Current program has been modified" and VampEffect.cpp:622 "Program" appear. I guess Steve knows the answer about Nyquist. Otherwise, those two look as if they could be left as is.
      • Steve 01Feb17: Re. Nyquist.cpp: "Current program has been modified", "program" is appropriate as it refers to the Nyquist script code.

Export Multiple dialog

The "Format:" dropdown

Current text:

"(external program)"

Suggested replacement:

"(external application)"


Interface Preferences

The checkbox "Show 'How to Get Help' dialog box at program startup"

Current text:

"Show 'How to Get Help' dialog box at program startup"

Suggested replacement:

"Show 'How to Get Help' dialog box at application startup" or "Show 'How to Get Help' dialog box at startup"

The second alternative is consistent with the Welcome message


Warning dialog

Low disk space

Current text:

"Low disk space at program startup"

Suggested replacement:

"Low disk space at application startup"


Manual pages affected by these proposed changes

Done

  • Auto-select, if selection required
  • "Disk space remains for recording xxx hours and yy minutes" to "Disk space remaining for recording: xxx hours and yy minutes".
  • "Select > Region > "Ends to Zero Crossings" to Select > "At Zero Crossings".
  • "To use Draw, choose 'Waveform' in the Track Drop-down Menu" to "To use Draw, choose 'Waveform' or 'Waveform dB' in the Track Dropdown Menu.".
  • Actions done by Transcription Toolbar and its tooltip now have "Speed" capitalised.
  • No ellipses in title bar of file open/import dialogs.
  • Auto Recovery "Discard" dialogs say only recoverable projects are discarded.
  • Capitalised button in Dependency dialogue per MS guidelines.
  • Edit Metadata Tags dialog always titled as that, even when exporting.
  • Tracks Preferences: Changed "Select all audio in project, if none selected" to clearer "Select then act on entire project, if no region selected".
  • Changed "for this to use" to "to perform this action' in some "Disallowed" dialogs.
  • Locate LAME dialog: Capitalize LAME.
  • Error importing dialog: Mention FFmpeg and show actual menu path to Import Raw Data.
  • Recording Preferences playthrough text: "Listen while recording or monitoring new track (uncheck when recording "stereo mix")" changed to "Listen to input while recording or monitoring (uncheck when recording computer playback)".
  • Scrubbing tooltips finalized as "Click & move to Scrub. Click & drag to Seek."
  • Timer Recording capitalization fixes.
  • Timer Recording Disk Space Warning: "Recording time remaining on disc" to "Recording time remaining on disk"
  • Welcome message reworked for better and clearer layout and text
  • Sequence.cpp More friendly warning for overlong Block File "Truncating Overlong Block File" with text "Sequence has block file exceeding maximum %s samples per block. Truncating to this maximum length.".
  • About Dialog: OK... Audacious!" button changed to "OK".
  • "Leveller" name in interface changed to "Leveler".
  • RecordingPrefs.cpp: Add "Overdub" to read: "Overdub: Play other tracks while recording new one".
  • DirectoriesPrefs.cpp: reword audio cache preference to "Play and/or record using RAM (useful for slow drives, but could crash with long files or recordings)." Remove "AutoSave" choice.
  • TrackPanel.cpp: "Draw currently only works with linear-view waveforms" > "To use Draw, choose 'Waveform' in the Track Drop-down Menu"
  • Import / Export Preferences: Remove duplicated "When importing audio" from "Normalize all tracks in project"
  • Import.cpp: Add file type exclusions for MIDI, other notes-based formats, Musepack, Wavpack, AC3 and Speex.
  • Import.cpp: Remove exclusion of .mpa format as it's a valid MPEG-1 format.
  • Interface tab: Change to "Closing last window quits Audacity" (similar, slightly shorter wording to that in 1.3.3)
  • ExportPCM.cpp: Options dialog for "WAV, AIFF, and other uncompressed types" changed from "Specify PCM Options" to "Specify Uncompressed Options"
  • Generate Menu: change inconsistent wordings in Chirp, DTMF, Noise, Silence, Tone to "Duration:"
  • Project.cpp: change text when opening 1.x project to "This file was saved by Audacity (1.x.x), a much\nolder version. The format has changed.\nAudacity could corrupt the file in opening\nit, so you must back it up first.\n\nOpen this file now?"
  • Tracks menu > Resample: change to "New sample rate (Hz)"
  • Interface tab: change to "Display range minimum for 'waveform (dB)' view"
  • Autorecovery.cpp: change to "Confirm?" dialog header and text "Are you sure you don't want to recover any projects? They can't be recovered later."
  • Both "OK...Audacious" buttons to "OK".
  • Project.cpp: change to "This file was saved by Audacity (1.2.6). You can open\nthe file with this version of Audacity, but if you save it with this version\nyou will no longer be able to open it in older versions.\n\nOpen this file now?"
  • HelpText.cpp: remove duplicated links and make "[burnCD|burn to a CD]]" a bullet
  • Credit to Chris Cannam on the "Audacity" tab of "About Audacity" for Vamp.
  • Interface tab: remove preference "Present track number to accessibility aid"
  • MP3 Export Library Location, added under "when exporting tracks" Note: Export quality options for WAV, AIFF, MP3 and other formats can be chosen by clicking the Options button at time of export.
  • Audio to buffer: (higher = more latency)
  • Latency correction: (negative = backwards)
  • If you want to burn your work to an audio CD for standalone CD players, you must first in HelpText.cpp
  • a WAV, AIFF or MP3. If burning to an audio CD for standalone CD players, you must export as WAV or AIFF. in Helptext.cpp.
  • Enable dragging of left and right selection edges added the word 'enable'.
  • MP3 Export Setup to MP3 Export Library Location which is what it is.
  • When exporting tracks to an audio file added emphasis, 'to an audio file'.
  • When saving a project... wording for dependencies and order of options changed.
  • When importing uncompressed audio files into Audacity to When importing uncompressed audio files
  • File Formats tab name changed to Audio Files
  • HelpText.cpp many wording changes, including fix to |<< and >>|.
  • Normalize on Load changed to When importing audio, normalize all tracks.
  • Innertext:Recording written and text on monitoring added
  • Innertext:Export written and three typos corrected.
  • Innertext:Editing written and title changed to 'Editing and Greyed out Menus'.
  • Save Changes? Dialogue with empty Project: changed from "\n\nSaved project will be empty!!\n\nTo save the tracks you previously\nhad, click cancel, restore the tracks\nusing undo, and then save." to "\n\nSaved project will be empty!!\n\nTo save the tracks that were previously\nopen, click Cancel, Edit > Undo until all your\ntracks are open, then File > Save Project."
  • Interface tab, Show/Hide: "Show Welcome Message at program start up" , was 'Splash Screen'.
  • Find Clipping: "Start and stop must be greater than 0", was 'positive and greater than zero'.
  • Dependencies dialogue: The former "Close" and "Skip" buttons now both read "Do not copy any audio".
  • Export Multiple progress dialogue: "Exporting the entire project as a WAV/AIFF file" or (for MP3) "exporting the entire file..." now changed to "Exporting entire project" with (file name) in the dialogue title and (format) above the progress bar.
  • Latency Shift Dialogue: In "I have brought it back to start at zero", "I have" has been replaced with "Audacity has".
  • Preferences: Interface tab: "Tracks &fit vertically zoomed" changed to "Automatically &fit tracks vertically zoomed"
  • "Audacious!" buttons -> "OK... Audacious!"
  • GUIPrefs.CPP:

- "&Select all audio, if none selected, on applying effect"

+ "&Select all audio in project, if none selected"

- "&Circular track keyboard navigation"

+ "\"Move track focus\" &cycles repeatedly through tracks"

- "&Quit Audacity upon closing last window"

+ "Any Close/Exit command completely &quits Audacity"


  • Import.CPP:

- " is an encrypted audio file, typically from an online music store. \nAudacity cannot open this type of file due to the encryption.\nYou need to convert it to a supported, unencrypted audio format."

+ " is an encrypted audio file. These typically are from an online music store. \nAudacity cannot open this type of file due to the encryption. \nTry recording the file into Audacity, or burn it to audio CD then \nextract the CD track to a supported audio format such as WAV or AIFF."

- " is an audio CD file. \nAudacity does not open this type of file.\nTry ripping it to a native audio format that Audacity can import."

+ " is an audio CD track. \nAudacity cannot open audio CDs directly. \nExtract (rip) the CD tracks to an audio format that \nAudacity can import, such as WAV or AIFF.");

Add "WAV or AIFF" references to Real, AAC and WMA:

- " is a RealPlayer media file. \nAudacity cannot open this..."

+ " is a RealPlayer media file. \nAudacity cannot open this proprietary format. \nYou need to convert it to a supported audio format, such as WAV or AIFF."

- " is an Advanced Audio Coding file. \nAudacity cannot open this..."

+ " is an Advanced Audio Coding file. \nAudacity cannot open this type of file. \nYou need to convert it to a supported audio format, such as WAV or AIFF."

- " is a Windows Media Audio file. \nAudacity cannot open this..."

+ " is a Windows Media Audio file. \nAudacity cannot open this type of file due to patent restrictions. \nYou need to convert it to a supported audio format, such as WAV or AIFF."


  • Default temporary directory: changed from "/tmp/audacity1.2-%USERNAME" to AUDACITY_VERSION, AUDACITY_RELEASE string
Personal tools

Donate securely by PayPal, using your credit card or PayPal account!